Bug 127526 - glibc-kernheaders breaks dosfstools build
Summary: glibc-kernheaders breaks dosfstools build
Status: CLOSED DUPLICATE of bug 134834
Alias: None
Product: Fedora
Classification: Fedora
Component: dosfstools (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-09 12:59 UTC by Steve Grubb
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
new patch for dosfstools (394 bytes, patch)
2004-09-06 13:56 UTC, Steve Grubb
no flags Details | Diff

Description Steve Grubb 2004-07-09 12:59:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
The latest version of glibc-kernheaders breaks the build of dosfstools:

/usr/include/linux/msdos_fs.h:115: error: parse error before "__s8"
/usr/include/linux/msdos_fs.h:118: error: parse error before "sector_size"
/usr/include/linux/msdos_fs.h:119: error: parse error before
"cluster_size"


The problem is that linux/types.h is not being included. This defines
__s8 & __u8
among other things. I created this patch:

diff -ur glibc-kernheaders-2.4.orig/usr/include/linux/msdos_fs.h
glibc-kernheaders-2.4/usr/include/linux/msdos_fs.h
--- glibc-kernheaders-2.4.orig/usr/include/linux/msdos_fs.h     2003-08-03
07:44:11.000000000 -0400
+++ glibc-kernheaders-2.4/usr/include/linux/msdos_fs.h  2004-07-08
08:02:15.000000000 -0400
@@ -7,6 +7,7 @@
 #include <linux/fs.h>
 #include <linux/stat.h>
 #include <linux/fd.h>
+#include <linux/types.h>
                                                                     
          
 #define MSDOS_ROOT_INO  1 /* == MINIX_ROOT_INO */
 #define SECTOR_SIZE     512 /* sector size (bytes) */


And I also had to patch mkdosfs.c to include linux/types.h. I don't
think this is normal and I'll probably need more patching in various
packages.

Version-Release number of selected component (if applicable):
glibc-kernheaders-2.4-9.1.84

How reproducible:
Always

Steps to Reproduce:
1. rpm -ivh glibc-kernheaders-2.4-9.1.84.i386.rpm
2. rpm -ivh dosfstools-2.8-12.src.rpm
3. rpmbuild -bb /usr/src/redhat/SPECS/dosfstools.spec
    

Additional info:

Dosfstools cannot compile with glibc-kernheaders in its current state.
glibc-kernheaders-2.4-9.src.rpm was fine and did not exhibit this problem.

Comment 1 Arjan van de Ven 2004-08-03 14:12:41 UTC
fixed for the next build

Comment 2 Florian La Roche 2004-09-06 13:27:58 UTC
Re-open, not fixed in current tree

Comment 3 Arjan van de Ven 2004-09-06 13:53:32 UTC
dosfstools is broken itself
it uses __u8 *in it's own C code* without including <asm/types.h>
the original complaint of this bug was that some header used __u8
without that header also including the definition of those types; that
got fixed. However the app itself forgetting to include them we can't
fix obviously.


Comment 4 Steve Grubb 2004-09-06 13:56:45 UTC
Created attachment 103509 [details]
new patch for dosfstools

The current status of this problem report is that the patch to
glibc-kernheaders I submitted is no longer needed. However, dosfstools still
does not compile without patching. I will attach a patch that I apply to
dosfstools in case fixing dosfstools is the approach taken; or it has some
insight into the issue.

Comment 5 Peter Vrabec 2004-10-07 13:13:15 UTC
Problem solved by Jeremy Katz patch in dosfstools-2.8-14.
Resolved as duplicate of #134834

*** This bug has been marked as a duplicate of 134834 ***

Comment 6 Red Hat Bugzilla 2006-02-21 19:04:22 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.