Bug 134834 - Rebuilding of dosfstools dies with 'syntax error before "__u8"'
Rebuilding of dosfstools dies with 'syntax error before "__u8"'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dosfstools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Ben Levenson
:
: 127526 (view as bug list)
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-10-06 12:19 EDT by Robert Scheck
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-06 13:17:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-10-06 12:19:03 EDT
Description of problem:
If I try to rebuild dosfstools, I die with the following error 
message (and hundred of error lines below):

--- snipp ---
make -C mkdosfs all
make[1]: Entering directory `/usr/src/redhat/BUILD/dosfstools-2.8/mkdosfs'
gcc -O2 -g -march=i386 -mcpu=i686 -Dllseek=lseek64 -D_LARGEFILE64_SOURCE -c mkdosfs.c -o mkdosfs.o
mkdosfs.c:169: syntax error before "__u8"
mkdosfs.c:169: warning: no semicolon at end of struct or union
mkdosfs.c:170: warning: data definition has no type or storage class
mkdosfs.c:171: syntax error before "ext_boot_sign"
mkdosfs.c:171: warning: data definition has no type or storage class
mkdosfs.c:172: syntax error before "volume_id"
[...]
--- snapp ---

Version-Release number of selected component (if applicable):
dosfstools-2.8-13

Actual results:
Rebuilding dies with an error.

Expected results:
Rebuilding without any error.
Comment 1 Jeremy Katz 2004-10-06 13:17:58 EDT
Fixed in -14
Comment 2 Peter Vrabec 2004-10-07 09:13:23 EDT
*** Bug 127526 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.