Bug 1275368 - [abrt] wammu: _windows.py:4:<module>:ImportError: /usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_windows_.so: symbol _ZThn696_N13wxHtmlListBox10RefreshAllEv, version WXU_3.0 not defined in file libwx_gtk3u_html-3.0.so.0 with link time reference [NEEDINFO]
[abrt] wammu: _windows.py:4:<module>:ImportError: /usr/lib64/python2.7/site-p...
Status: CLOSED DUPLICATE of bug 1268984
Product: Fedora
Classification: Fedora
Component: wxGTK3 (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeremy Newton
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:ddc8f7e3e79f751d8da72693b40...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-26 13:00 EDT by tux49
Modified: 2015-10-30 21:09 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-30 21:09:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
swt: needinfo? (gilles.ernoult)


Attachments (Terms of Use)
File: backtrace (7.12 KB, text/plain)
2015-10-26 13:00 EDT, tux49
no flags Details
File: environ (1.52 KB, text/plain)
2015-10-26 13:00 EDT, tux49
no flags Details

  None (edit)
Description tux49 2015-10-26 13:00:11 EDT
Version-Release number of selected component:
wammu-0.38-2.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python /usr/bin/wammu
dso_list:       wxPython-3.0.2.0-7.fc23.x86_64
executable:     /usr/bin/wammu
kernel:         4.2.3-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
#1 <module> in /usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_windows.py:4
#2 <module> in /usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_core.py:16921
#3 <module> in /usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/__init__.py:45
#4 <module> in /usr/lib/python2.7/site-packages/Wammu/Locales.py:31
#5 <module> in /usr/bin/wammu:31
Comment 1 tux49 2015-10-26 13:00:16 EDT
Created attachment 1086556 [details]
File: backtrace
Comment 2 tux49 2015-10-26 13:00:18 EDT
Created attachment 1086557 [details]
File: environ
Comment 3 Sergio Monteiro Basto 2015-10-26 18:10:20 EDT
tux49 already use testing version [1] and looks like wxPython issue when I saw this in backtrace: 

_windows.py:4:<module>:ImportError: /usr/lib64/python2.7/site-packages/wx-3.0-gtk3/wx/_windows_.so: symbol _ZThn696_N13wxHtmlListBox10RefreshAllEv, version WXU_3.0 not defined in file libwx_gtk3u_html-3.0.so.0 with link time reference



[1] https://bodhi.fedoraproject.org/updates/?packages=wxPython
Comment 4 Scott Talbert 2015-10-27 19:26:51 EDT
tux49, what version of wxGTK3 package do you have installed?
Comment 5 Sergio Monteiro Basto 2015-10-27 21:16:48 EDT
dso_list:       wxPython-3.0.2.0-7.fc23.x86_64
Comment 6 Scott Talbert 2015-10-28 11:49:31 EDT
*wxGTK3* version not wxPython, e.g., "rpm -q wxGTK3"
Comment 7 Scott Talbert 2015-10-29 20:13:30 EDT
I can't reproduce this on a fresh F23 install.  tux49 (or anyone that can reproduce this), can you please run these commands and provide the output:

readelf -Ws /usr/lib64/libwx_gtk3u_html-3.0.so.0 | grep _ZThn696_N13wxHtmlListBox10RefreshAllEv

rpm -q wxGTK3
Comment 8 Scott Talbert 2015-10-30 21:09:08 EDT

*** This bug has been marked as a duplicate of bug 1268984 ***

Note You need to log in before you can comment on or make changes to this bug.