Bug 1275619 - tests fail on big endian arches
tests fail on big endian arches
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libndn-cxx (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susmit
Fedora Extras Quality Assurance
:
: 1297894 (view as bug list)
Depends On:
Blocks: ZedoraTracker PPCTracker
  Show dependency treegraph
 
Reported: 2015-10-27 07:05 EDT by Dan Horák
Modified: 2016-06-27 13:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-27 13:16:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2015-10-27 07:05:22 EDT
Tests are failing on big endian arches like s390(x) or ppc64

from build.log
...
Executing(%check): /bin/sh -e /var/tmp/rpm-tmp.2MciND
+ umask 022
+ cd /builddir/build/BUILD
+ cd ndn-cxx-ndn-cxx-0.3.4
+ export LD_LIBRARY_PATH=/builddir/build/BUILD/ndn-cxx-ndn-cxx-0.3.4/build
+ LD_LIBRARY_PATH=/builddir/build/BUILD/ndn-cxx-ndn-cxx-0.3.4/build
+ build/unit-tests
Running 607 test cases...
../tests/unit-tests/interest.t.cpp(887): error in "Decode": check i.getNonce() == 1U failed [16777216 != 1]
../tests/unit-tests/interest.t.cpp(907): error in "DecodeFromStream": check i.getNonce() == 1U failed [16777216 != 1]
../tests/unit-tests/interest.t.cpp(931): error in "Encode": check { Interest1, Interest1 + sizeof(Interest1) } == { wire.begin(), wire.end() } failed. 
Mismatch in a position 83:  != �
Mismatch in a position 86: � != 
../tests/unit-tests/interest.t.cpp(940): error in "Encode": check { Interest2, Interest2 + sizeof(Interest2) } == { wire.begin(), wire.end() } failed. 
Mismatch in a position 83:  != �
Mismatch in a position 86: � != 
../tests/unit-tests/name.t.cpp(408): error in "Compare": check -1 == Name("/A") .compare(Name("/B")) failed [-1 != -2]
../tests/unit-tests/name.t.cpp(417): error in "Compare": check -1 == Name("/Z/A/Y") .compare(1, 1, Name("/B")) failed [-1 != -2]
../tests/unit-tests/name.t.cpp(426): error in "Compare": check -1 == Name("/Z/A") .compare(1, Name::npos, Name("/B")) failed [-1 != -2]
../tests/unit-tests/name.t.cpp(435): error in "Compare": check -1 == Name("/Z/A/Y") .compare(1, 1, Name("/X/B/W"), 1, 1) failed [-1 != -2]
../tests/unit-tests/name.t.cpp(444): error in "Compare": check -1 == Name("/Z/A/Y") .compare(1, 1, Name("/X/B"), 1) failed [-1 != -2]
*** 9 failures detected in test suite "ndn-cxx Unit Tests"
error: Bad exit status from /var/tmp/rpm-tmp.2MciND (%check)

for full logs please see http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2833893 or http://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1971883

Version-Release number of selected component (if applicable):
libndn-cxx-0.3.4-4.fc23
Comment 1 Susmit 2015-10-27 10:14:56 EDT
Thanks reported to upstream.

http://redmine.named-data.net/issues/3294
Comment 2 Marcin Juszkiewicz 2015-11-10 04:55:57 EST
https://github.com/named-data/ndn-cxx/pull/3 should fix "Compare" part which also exists on AArch64.
Comment 3 Marcin Juszkiewicz 2016-01-19 08:06:09 EST
*** Bug 1297894 has been marked as a duplicate of this bug. ***
Comment 4 Jan Kurik 2016-02-24 08:52:50 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 5 Ngo Than 2016-06-27 13:16:25 EDT
it's fixed in libndn-cxx-0.4.x

Note You need to log in before you can comment on or make changes to this bug.