Bug 1297894 - libndn-cxx-0.4.0 build failure on ppc64
libndn-cxx-0.4.0 build failure on ppc64
Status: CLOSED DUPLICATE of bug 1275619
Product: Fedora
Classification: Fedora
Component: libndn-cxx (Show other bugs)
rawhide
ppc64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Susmit
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PPCTracker
  Show dependency treegraph
 
Reported: 2016-01-12 12:29 EST by Ngo Than
Modified: 2016-01-19 08:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-19 08:06:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ngo Than 2016-01-12 12:29:49 EST
Description of problem:

+ build/unit-tests
Running 607 test cases...
../tests/unit-tests/interest.t.cpp(887): error: in "TestInterest/Decode": check i.getNonce() == 1U has failed [16777216 != 1]
../tests/unit-tests/interest.t.cpp(907): error: in "TestInterest/DecodeFromStream": check i.getNonce() == 1U has failed [16777216 != 1]
../tests/unit-tests/interest.t.cpp(931): error: in "TestInterest/Encode": check { Interest1, Interest1 + sizeof(Interest1) } == { wire.begin(), wire.end() } has failed. 
Mismatch at position 83: 0x1 != 0
Mismatch at position 0x56: 0 != 0x1
../tests/unit-tests/interest.t.cpp(940): error: in "TestInterest/Encode": check { Interest2, Interest2 + sizeof(Interest2) } == { wire.begin(), wire.end() } has failed. 
Mismatch at position 83: 0x2 != 0
Mismatch at position 0x56: 0 != 0x2
*** 4 failures are detected in the test module "ndn-cxx Unit Tests"
Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1. ppc-koji build --scratch f24 ppc-koji build --scratch f24 libndn-cxx-0.4.0-1.fc24.src.rpm


Actual results:
http://ppc.koji.fedoraproject.org/kojifiles/work/tasks/9376/3049376/build.log

Expected results:
it should build fine
Comment 1 Susmit 2016-01-12 13:41:30 EST
Thanks. We are already working on it.
Comment 2 Marcin Juszkiewicz 2016-01-19 08:06:09 EST

*** This bug has been marked as a duplicate of bug 1275619 ***

Note You need to log in before you can comment on or make changes to this bug.