Bug 1275677 - Crontab errors in log
Crontab errors in log
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Nick Carboni
amogh
appliance
: ZStream
Depends On:
Blocks: 1289321
  Show dependency treegraph
 
Reported: 2015-10-27 09:27 EDT by Thom Carlin
Modified: 2016-06-29 11:01 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289321 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:01:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-10-27 09:27:34 EDT
Description of problem:

Multiple messages in evm.log relating to cron

Version-Release number of selected component (if applicable):

5.5.0.7-beta1.3.20151021133253_ed40d96

How reproducible:

100%

Steps to Reproduce:
1. Spin up appliance
2. Examine logs
3.

Actual results:

Errors in log

Expected results:

No errors

Additional info:

evm.excerpts:

[----] I, [2015-10-22T08:07:24.819434 #13968:567994]  INFO -- : MIQ(MiqServer#ntp_reload) Synchronizing ntp settings: {:server=>["0.pool.ntp.org", "1.pool.ntp.org", "2.pool.ntp.org"]}
no crontab for root
[...]
[----] I, [2015-10-27T07:54:09.089227 #2745:693994]  INFO -- : MIQ(MiqServer#ntp_reload) Synchronizing ntp settings: {:server=>["0.pool.ntp.org", "1.pool.ntp.org", "2.pool.ntp.org"]}
"/tmp/new_crontab":1: bad minute
errors in crontab file, can't install.
Comment 2 Nick Carboni 2015-11-04 10:14:33 EST
Those seem to be INFO messages. Is there anything other than lines in the log that we can investigate? Is there some functionality that is not working that is related to these messages?
Comment 3 Thom Carlin 2015-11-04 10:22:30 EST
I'm unclear on what functionality is other than vmdb/gems/pending/util/ntp/cron_ntpdate uses this.  Can you explain what is happening in this gem?
Comment 4 Nick Carboni 2015-11-04 12:00:56 EST
For instance, are you seeing time drift as a result of something around ntp malfunctioning?  In my opinion, INFO messages in the log alone do not warrant a bug report.
Comment 7 CFME Bot 2015-12-07 10:25:47 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/3ba88b3c5ccfda4d6d6fe2bc8b5c96c17e827d94

commit 3ba88b3c5ccfda4d6d6fe2bc8b5c96c17e827d94
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Fri Dec 4 11:58:47 2015 -0500
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Fri Dec 4 14:16:49 2015 -0500

    Updated linux_admin gem version
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1275677

 gems/pending/Gemfile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
Comment 8 CFME Bot 2015-12-07 10:25:52 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/011b8b17e3811d2f7bf5b24f408ab1282ef731b1

commit 011b8b17e3811d2f7bf5b24f408ab1282ef731b1
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Wed Dec 2 14:15:29 2015 -0500
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Fri Dec 4 15:53:57 2015 -0500

    Removed now unused MiqNtp code
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1275677

 gems/pending/util/ntp/cron_ntpdate |  41 ---------------
 gems/pending/util/ntp/miq-ntp.rb   |  56 --------------------
 gems/pending/util/ntp/run_ntpdate  | 102 -------------------------------------
 3 files changed, 199 deletions(-)
 delete mode 100755 gems/pending/util/ntp/cron_ntpdate
 delete mode 100644 gems/pending/util/ntp/miq-ntp.rb
 delete mode 100755 gems/pending/util/ntp/run_ntpdate
Comment 9 CFME Bot 2015-12-07 10:26:01 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/194c06759ed329dd35aa24b720bb6f7dca7df9df

commit 194c06759ed329dd35aa24b720bb6f7dca7df9df
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Tue Dec 1 17:07:11 2015 -0500
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Fri Dec 4 15:53:56 2015 -0500

    Using chrony for time sync instead of ntpdate
    
    ntpdate is to be retired and chronyd is the new default
    time sync daemon on Centos 7 and has been running on the
    appliance along side our code running ntpdate. This opens
    up the possibility of trying to sync with both the timeservers
    configured in `/etc/chrony.conf` which have always been set to the
    defaults and `/etc/ntp.conf` which is what is edited when the user
    changes ntp servers.
    
    Also the motivation behind using a custom script which ran ntpdate
    was to have the schedule worker protected from large jumps in time
    by dropping an exit file and waiting for it to exit.
    
    The schedule worker has not responded to the exit file since
    commit 85d34a9a869ce2eefcf69d7c58644a24cc2359ba was merged in 2012.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1275677

 app/models/miq_server/ntp_management.rb | 16 +++++++++++++---
 spec/models/miq_server_spec.rb          | 16 ++++++++++++----
 2 files changed, 25 insertions(+), 7 deletions(-)
Comment 10 Nick Carboni 2015-12-07 12:56:39 EST
Removed code around using ntpdate, so moving this to POST.

We now do all time sync through chronyd.
Comment 11 amogh 2016-04-26 16:28:06 EDT
verified in 5.6.0.4-beta2.3.20160421172650_719e256.

error not present in evm.log. chrony.conf file is present at /etc/

[root@appliance log]# find / -name chrony.conf
/etc/chrony.conf

[root@appliance log]# grep -C 20 "Synchronizing ntp settings" evm.log | grep "crontab"
[root@appliance log]#
Comment 13 errata-xmlrpc 2016-06-29 11:01:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.