This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1289321 - Crontab errors in log
Crontab errors in log
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.2
Assigned To: Nick Carboni
Kyrylo Zvyagintsev
: ZStream
Depends On: 1275677
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-07 15:57 EST by John Prause
Modified: 2016-02-10 10:25 EST (History)
7 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1275677
Environment:
Last Closed: 2016-02-10 10:25:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 CFME Bot 2015-12-11 09:43:09 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=2a9e76a99e4208ca8bad687a75b14641139696bc

commit 2a9e76a99e4208ca8bad687a75b14641139696bc
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Tue Dec 1 17:07:11 2015 -0500
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Thu Dec 10 14:23:31 2015 -0500

    Using chrony for time sync instead of ntpdate
    
    ntpdate is to be retired and chronyd is the new default
    time sync daemon on Centos 7 and has been running on the
    appliance along side our code running ntpdate. This opens
    up the possibility of trying to sync with both the timeservers
    configured in `/etc/chrony.conf` which have always been set to the
    defaults and `/etc/ntp.conf` which is what is edited when the user
    changes ntp servers.
    
    Also the motivation behind using a custom script which ran ntpdate
    was to have the schedule worker protected from large jumps in time
    by dropping an exit file and waiting for it to exit.
    
    The schedule worker has not responded to the exit file since
    commit 85d34a9a869ce2eefcf69d7c58644a24cc2359ba was merged in 2012.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289321

 app/models/miq_server/ntp_management.rb | 16 +++++++++++++---
 spec/models/miq_server_spec.rb          | 16 ++++++++++++----
 2 files changed, 25 insertions(+), 7 deletions(-)
Comment 4 CFME Bot 2015-12-11 09:43:14 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=49e4bd59c32b4fa36914886435c2bad73a813b67

commit 49e4bd59c32b4fa36914886435c2bad73a813b67
Merge: 56dfe71 c8a7c58
Author:     Gregg Tanzillo <gtanzill@redhat.com>
AuthorDate: Fri Dec 11 09:37:44 2015 -0500
Commit:     Gregg Tanzillo <gtanzill@redhat.com>
CommitDate: Fri Dec 11 09:37:44 2015 -0500

    Merge branch 'backport_use_chrony_instead_of_ntpdate' into '5.5.z'
    
    Use chrony instead of ntpdate
    
    ntpdate is to be retired and chronyd is the new default
    time sync daemon on Centos 7 and has been running on the
    appliance along side our code running ntpdate. This opens
    up the possibility of trying to sync with both the timeservers
    configured in `/etc/chrony.conf` which have always been set to the
    defaults and `/etc/ntp.conf` which is what is edited when the user
    changes ntp servers.
    
    Also the motivation behind using a custom script which ran ntpdate
    was to have the schedule worker protected from large jumps in time
    by dropping an exit file and waiting for it to exit.
    
    The schedule worker has not responded to the exit file since
    commit 85d34a9a was merged in 2012.
    
    Upstream PR: https://github.com/ManageIQ/manageiq/pull/5705
    
    Two empty commits in upstream not cherry-picked to this branch. The other cherry-picks were clean.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289321
    
    See merge request !609

 app/models/miq_server/ntp_management.rb |  16 ++++-
 gems/pending/util/ntp/cron_ntpdate      |  41 -------------
 gems/pending/util/ntp/miq-ntp.rb        |  56 ------------------
 gems/pending/util/ntp/run_ntpdate       | 102 --------------------------------
 spec/models/miq_server_spec.rb          |  16 +++--
 5 files changed, 25 insertions(+), 206 deletions(-)
Comment 5 CFME Bot 2015-12-11 09:43:37 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=c8a7c58cad936536ecd51751d37d45285fb7aa71

commit c8a7c58cad936536ecd51751d37d45285fb7aa71
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Wed Dec 2 14:15:29 2015 -0500
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Thu Dec 10 14:23:45 2015 -0500

    Removed now unused MiqNtp code
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1289321

 gems/pending/util/ntp/cron_ntpdate |  41 ---------------
 gems/pending/util/ntp/miq-ntp.rb   |  56 --------------------
 gems/pending/util/ntp/run_ntpdate  | 102 -------------------------------------
 3 files changed, 199 deletions(-)
 delete mode 100755 gems/pending/util/ntp/cron_ntpdate
 delete mode 100644 gems/pending/util/ntp/miq-ntp.rb
 delete mode 100755 gems/pending/util/ntp/run_ntpdate
Comment 8 errata-xmlrpc 2016-02-10 10:25:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.