Bug 1275712 - Unable to edit entrypoint unless catalog item is set to be displayed in catalog
Unable to edit entrypoint unless catalog item is set to be displayed in catalog
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Harpreet Kataria
luke couzens
service:catalog
:
Depends On:
Blocks: 1291871
  Show dependency treegraph
 
Reported: 2015-10-27 10:37 EDT by Pete Savage
Modified: 2016-06-29 11:01 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1291871 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:01:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
psavage: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Pete Savage 2015-10-27 10:37:07 EDT
Description of problem: Unable to edit entrypoint unless catalog item is set to be displayed in catalog


Version-Release number of selected component (if applicable): 5.5.0.7


How reproducible: 100%


Steps to Reproduce:
1. Create a catalog item and do not tick the "Display in catalog" checkbox
2. Once saved try to edit the item
3.

Actual results: Entrypoint is unavailable


Expected results: Entrypoint should be editable whether catalog item is in catalog or not.


Additional info:
Comment 3 Dave Johnson 2015-11-06 12:49:07 EST
Pete, can you make a comment on this please.  It sounds like we should turn this into a RFE.
Comment 4 Dave Johnson 2015-11-06 12:56:56 EST
Greg, I have a note to add a needinfo for you.  I believe you were going to weigh in this as well.
Comment 5 Pete Savage 2015-11-30 07:29:01 EST
To me, this is not an RFE, as I understand it if I want to create a catalog bundle, I could want the catalog items to still have their own initialization points. To do this, requires me to first "unhide" them, by displaying them in the catalog, and then to make the entrypoint edit, then to "hide" them again. It would only make sense to me to have these elements hidden if they were not used at all if the item was not in the catalog, but, as far as I can see, this is not the case.
Comment 6 Harpreet Kataria 2015-11-30 09:27:18 EST
Robin,

Can you look into this one, looks like a scrolling issue, i am not sure if this has already been fixed.

Thanks,
~Harpreet
Comment 7 Harpreet Kataria 2015-11-30 09:27:49 EST
ignore comment #6
Comment 9 Greg McCullough 2015-12-17 14:33:28 EST
Discussed with Tina and the UI should show all the fields even when "Display in Catalog" is de-selected.

Catalog - Allows catalog item to be groups with other similar items, but cannot be  ordered individually.

Dialog - Selectable but not required.  Allows a user to create a catalog item that they may change to display in catalog at a later time.

All Entry points work the same as they do when "Display in Catalog" is selected.
Comment 11 CFME Bot 2015-12-22 12:01:00 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/a546ae2371e28fe48a8125ede26c2d65298e99ee

commit a546ae2371e28fe48a8125ede26c2d65298e99ee
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Dec 16 16:51:40 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Dec 21 12:59:07 2015 -0500

    Made all fields visible on the form.
    
    - Entry Point fields, Catalog & Dialog fields were only visible when user checked to Display Catalog ITem in the Catalog, changed to make all fields visible on the form.
    - Change Provisioning Entry Point field to be required field even if Display in catalog is not selected.
    - Dialog field is only required when user has selected to display in Catalog.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1275712
    https://bugzilla.redhat.com/show_bug.cgi?id=1291871

 app/controllers/catalog_controller.rb        |  14 +-
 app/views/catalog/_form_basic_info.html.haml | 191 +++++++++++++--------------
 spec/controllers/catalog_controller_spec.rb  |   8 +-
 3 files changed, 106 insertions(+), 107 deletions(-)
Comment 13 CFME Bot 2016-01-04 17:27:16 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=5bda13be4365a0c2f9552d1658d66be88943f9d3

commit 5bda13be4365a0c2f9552d1658d66be88943f9d3
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Dec 16 16:51:40 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Jan 4 16:21:52 2016 -0500

    Made all fields visible on the form.
    
    - Entry Point fields, Catalog & Dialog fields were only visible when user checked to Display Catalog ITem in the Catalog, changed to make all fields visible on the form.
    - Change Provisioning Entry Point field to be required field even if Display in catalog is not selected.
    - Dialog field is only required when user has selected to display in Catalog.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1275712
    https://bugzilla.redhat.com/show_bug.cgi?id=1291871
    (cherry picked from commit a546ae2)

 app/controllers/catalog_controller.rb        |  14 +-
 app/views/catalog/_form_basic_info.html.haml | 191 +++++++++++++--------------
 spec/controllers/catalog_controller_spec.rb  |   8 +-
 3 files changed, 106 insertions(+), 107 deletions(-)
Comment 14 CFME Bot 2016-01-04 17:27:26 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=9682cf7a6c6993f0dd09d1ff9b2f24eb09f70578

commit 9682cf7a6c6993f0dd09d1ff9b2f24eb09f70578
Merge: 77677d5 5bda13b
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Jan 4 17:26:51 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Jan 4 17:26:51 2016 -0500

    Merge branch '55z_pr_5951' into '5.5.z'
    
    Made all fields visible on the form.
    
    - Entry Point fields, Catalog & Dialog fields were only visible when user checked to Display Catalog ITem in the Catalog, changed to make all fields visible on the form.
    - Change Provisioning Entry Point field to be required field even if Display in catalog is not selected.
    - Dialog field is only required when user has selected to display in Catalog.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1275712
    https://bugzilla.redhat.com/show_bug.cgi?id=1291871
    (cherry picked from commit a546ae2)
    
    @dclarizi please merge, this is clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/5951
    
    See merge request !670

 app/controllers/catalog_controller.rb        |  14 +-
 app/views/catalog/_form_basic_info.html.haml | 191 +++++++++++++--------------
 spec/controllers/catalog_controller_spec.rb  |   8 +-
 3 files changed, 106 insertions(+), 107 deletions(-)
Comment 15 luke couzens 2016-04-18 09:20:46 EDT
Verified in 5.6.0.1-beta2
Comment 17 errata-xmlrpc 2016-06-29 11:01:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.