Bug 1291871 - Unable to edit entrypoint unless catalog item is set to be displayed in catalog
Unable to edit entrypoint unless catalog item is set to be displayed in catalog
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.2
Assigned To: Harpreet Kataria
Taras Lehinevych
: ZStream
Depends On: 1275712
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-15 14:18 EST by John Prause
Modified: 2016-02-10 10:28 EST (History)
8 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1275712
Environment:
Last Closed: 2016-02-10 10:28:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 CFME Bot 2015-12-22 12:01:04 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/a546ae2371e28fe48a8125ede26c2d65298e99ee

commit a546ae2371e28fe48a8125ede26c2d65298e99ee
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Dec 16 16:51:40 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Dec 21 12:59:07 2015 -0500

    Made all fields visible on the form.
    
    - Entry Point fields, Catalog & Dialog fields were only visible when user checked to Display Catalog ITem in the Catalog, changed to make all fields visible on the form.
    - Change Provisioning Entry Point field to be required field even if Display in catalog is not selected.
    - Dialog field is only required when user has selected to display in Catalog.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1275712
    https://bugzilla.redhat.com/show_bug.cgi?id=1291871

 app/controllers/catalog_controller.rb        |  14 +-
 app/views/catalog/_form_basic_info.html.haml | 191 +++++++++++++--------------
 spec/controllers/catalog_controller_spec.rb  |   8 +-
 3 files changed, 106 insertions(+), 107 deletions(-)
Comment 6 CFME Bot 2016-01-04 17:27:21 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=5bda13be4365a0c2f9552d1658d66be88943f9d3

commit 5bda13be4365a0c2f9552d1658d66be88943f9d3
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Dec 16 16:51:40 2015 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Mon Jan 4 16:21:52 2016 -0500

    Made all fields visible on the form.
    
    - Entry Point fields, Catalog & Dialog fields were only visible when user checked to Display Catalog ITem in the Catalog, changed to make all fields visible on the form.
    - Change Provisioning Entry Point field to be required field even if Display in catalog is not selected.
    - Dialog field is only required when user has selected to display in Catalog.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1275712
    https://bugzilla.redhat.com/show_bug.cgi?id=1291871
    (cherry picked from commit a546ae2)

 app/controllers/catalog_controller.rb        |  14 +-
 app/views/catalog/_form_basic_info.html.haml | 191 +++++++++++++--------------
 spec/controllers/catalog_controller_spec.rb  |   8 +-
 3 files changed, 106 insertions(+), 107 deletions(-)
Comment 7 CFME Bot 2016-01-04 17:27:32 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=9682cf7a6c6993f0dd09d1ff9b2f24eb09f70578

commit 9682cf7a6c6993f0dd09d1ff9b2f24eb09f70578
Merge: 77677d5 5bda13b
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Jan 4 17:26:51 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Jan 4 17:26:51 2016 -0500

    Merge branch '55z_pr_5951' into '5.5.z'
    
    Made all fields visible on the form.
    
    - Entry Point fields, Catalog & Dialog fields were only visible when user checked to Display Catalog ITem in the Catalog, changed to make all fields visible on the form.
    - Change Provisioning Entry Point field to be required field even if Display in catalog is not selected.
    - Dialog field is only required when user has selected to display in Catalog.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1275712
    https://bugzilla.redhat.com/show_bug.cgi?id=1291871
    (cherry picked from commit a546ae2)
    
    @dclarizi please merge, this is clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/5951
    
    See merge request !670

 app/controllers/catalog_controller.rb        |  14 +-
 app/views/catalog/_form_basic_info.html.haml | 191 +++++++++++++--------------
 spec/controllers/catalog_controller_spec.rb  |   8 +-
 3 files changed, 106 insertions(+), 107 deletions(-)
Comment 9 Taras Lehinevych 2016-01-20 05:44:36 EST
Verified fixed in version 5.5.2.1
Comment 10 errata-xmlrpc 2016-02-10 10:28:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.