This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1275774 - gnome-abrt segmentation fault at startup
gnome-abrt segmentation fault at startup
Status: CLOSED DUPLICATE of bug 1275824
Product: Fedora
Classification: Fedora
Component: gnome-abrt (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 13:14 EDT by info@kobaltwit.be
Modified: 2016-11-30 19:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-27 16:41:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of gnome-abrt (8.28 MB, text/plain)
2015-10-27 13:43 EDT, info@kobaltwit.be
no flags Details

  None (edit)
Description info@kobaltwit.be 2015-10-27 13:14:28 EDT
Description of problem:
When starting gnome-abrt from the command line, I get this:

$ gnome-abrt 
/usr/lib64/python3.4/site-packages/gnome_abrt/application.py:41: Warning: g_path_get_basename: assertion 'file_name != NULL' failed
  app = wrappers.get_app_for_cmdline(cmdline)
/usr/lib64/python3.4/site-packages/gnome_abrt/application.py:41: Warning: g_strsplit: assertion 'string != NULL' failed
  app = wrappers.get_app_for_cmdline(cmdline)
Segmentation fault (core dumped)

Version-Release number of selected component (if applicable):
gnome-abrt-1.2.0-3.fc22.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Open shell (I'm using konsole as I'm running a Plasma session)
2. Enter gnome-abrt<enter>

Actual results:
gnome-abrt crashes as displayed above

Expected results:
gnome-abrt should launch and show my system crashes

Additional info:
Comment 1 info@kobaltwit.be 2015-10-27 13:43 EDT
Created attachment 1086946 [details]
strace of gnome-abrt

As requested on irc by striker, I'm adding an strace of the crash, generated with this command:
$ strace -Tttvfrs 1024 -o /tmp/gnome-abrt_$(date +%F).strace gnome-abrt
Comment 2 info@kobaltwit.be 2015-10-27 16:30:46 EDT
Just tested that this also happens on F23.

If it matters, I'm using sddm instead of gdm.

Whether the running session is Gnome or Plasma doesn't seem to matter. The crash happens in both environments.

It's kind of bad that gnome-abrt is crashing, because it now becomes way more difficult to submit crash reports (including gnome-abrt's own crash).
Comment 3 info@kobaltwit.be 2015-10-27 16:41:47 EDT
I figured out how to properly submit a bug report using abrt-cli for the gnome-abrt crash. So I'll mark this one as a duplicate.

*** This bug has been marked as a duplicate of bug 1275824 ***

Note You need to log in before you can comment on or make changes to this bug.