Bug 1275824 - [abrt] gnome-abrt: remove_quotes(): python3.4 killed by SIGSEGV
[abrt] gnome-abrt: remove_quotes(): python3.4 killed by SIGSEGV
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:ff5c2e9977da9eef7248f0c559a...
:
: 1275774 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 16:39 EDT by info@kobaltwit.be
Modified: 2016-11-30 19:50 EST (History)
7 users (show)

See Also:
Fixed In Version: libreport-2.6.4-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-04 19:21:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (155.65 KB, text/plain)
2015-10-27 16:39 EDT, info@kobaltwit.be
no flags Details
File: cgroup (190 bytes, text/plain)
2015-10-27 16:39 EDT, info@kobaltwit.be
no flags Details
File: core_backtrace (18.97 KB, text/plain)
2015-10-27 16:39 EDT, info@kobaltwit.be
no flags Details
File: dso_list (16.03 KB, text/plain)
2015-10-27 16:39 EDT, info@kobaltwit.be
no flags Details
File: environ (2.52 KB, text/plain)
2015-10-27 16:39 EDT, info@kobaltwit.be
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-27 16:39 EDT, info@kobaltwit.be
no flags Details
File: maps (75.80 KB, text/plain)
2015-10-27 16:39 EDT, info@kobaltwit.be
no flags Details
File: mountinfo (5.43 KB, text/plain)
2015-10-27 16:39 EDT, info@kobaltwit.be
no flags Details
File: namespaces (85 bytes, text/plain)
2015-10-27 16:39 EDT, info@kobaltwit.be
no flags Details
File: open_fds (2.27 KB, text/plain)
2015-10-27 16:39 EDT, info@kobaltwit.be
no flags Details
File: proc_pid_status (1.01 KB, text/plain)
2015-10-27 16:39 EDT, info@kobaltwit.be
no flags Details
File: var_log_messages (28 bytes, text/plain)
2015-10-27 16:39 EDT, info@kobaltwit.be
no flags Details

  None (edit)
Description info@kobaltwit.be 2015-10-27 16:39:30 EDT
Description of problem:
I'm trying to run gnome-abrt on my system (Fedora 22, Plasma desktop).
It crashes with the info found in this report.

I also tried running it in a gnome environment. Same crash.

It may be relevant that I'm running sddm instead of gdm, in case this sets up
a different environment ?

Note I also tried this on a Fedora 23 machine - same crash.

Version-Release number of selected component:
gnome-abrt-1.2.0-3.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/bin/python3 /bin/gnome-abrt
crash_function: remove_quotes
executable:     /usr/bin/python3.4
global_pid:     11269
kernel:         4.1.6-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 remove_quotes at desktop-utils.c:42
 #1 problem_create_app_from_cmdline at desktop-utils.c:220
 #2 p_get_app_for_cmdline at problem_app.c:30
 #3 call_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4263
 #4 PyEval_EvalFrameEx at /usr/src/debug/Python-3.4.2/Python/ceval.c:2860
 #5 fast_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4360
 #6 call_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4288
 #7 PyEval_EvalFrameEx at /usr/src/debug/Python-3.4.2/Python/ceval.c:2860
 #8 fast_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4360
 #9 call_function at /usr/src/debug/Python-3.4.2/Python/ceval.c:4288
Comment 1 info@kobaltwit.be 2015-10-27 16:39:35 EDT
Created attachment 1087043 [details]
File: backtrace
Comment 2 info@kobaltwit.be 2015-10-27 16:39:36 EDT
Created attachment 1087044 [details]
File: cgroup
Comment 3 info@kobaltwit.be 2015-10-27 16:39:38 EDT
Created attachment 1087045 [details]
File: core_backtrace
Comment 4 info@kobaltwit.be 2015-10-27 16:39:40 EDT
Created attachment 1087046 [details]
File: dso_list
Comment 5 info@kobaltwit.be 2015-10-27 16:39:41 EDT
Created attachment 1087047 [details]
File: environ
Comment 6 info@kobaltwit.be 2015-10-27 16:39:43 EDT
Created attachment 1087048 [details]
File: limits
Comment 7 info@kobaltwit.be 2015-10-27 16:39:45 EDT
Created attachment 1087049 [details]
File: maps
Comment 8 info@kobaltwit.be 2015-10-27 16:39:46 EDT
Created attachment 1087050 [details]
File: mountinfo
Comment 9 info@kobaltwit.be 2015-10-27 16:39:48 EDT
Created attachment 1087051 [details]
File: namespaces
Comment 10 info@kobaltwit.be 2015-10-27 16:39:49 EDT
Created attachment 1087052 [details]
File: open_fds
Comment 11 info@kobaltwit.be 2015-10-27 16:39:50 EDT
Created attachment 1087053 [details]
File: proc_pid_status
Comment 12 info@kobaltwit.be 2015-10-27 16:39:52 EDT
Created attachment 1087054 [details]
File: var_log_messages
Comment 13 info@kobaltwit.be 2015-10-27 16:41:47 EDT
*** Bug 1275774 has been marked as a duplicate of this bug. ***
Comment 14 Jakub Filak 2015-10-27 17:44:26 EDT
Sorry for the inconvenience, this is a bug in libreport. The problem is that you have installed a desktop file for which g_app_info_get_commandline() returns a value that cannot be divided into string tokens delimited by " " by g_strsplit().

https://github.com/abrt/libreport/blob/master/src/gtk-helpers/desktop-utils.c#L219
Comment 15 Jakub Filak 2015-10-27 20:47:25 EDT
Upstream commit https://github.com/abrt/libreport/commit/01204ee26dfd48b734efdf0dd01dd8e87f6a9543 fixes the bug.
Comment 16 info@kobaltwit.be 2015-11-01 12:49:08 EST
That fixes it indeed on my systems, thanks !

Will this be backported or should I wait for the next release of libreport to get this fix via official channels ?
Comment 17 Matej Habrnal 2016-02-02 05:04:41 EST
It will be backported to Fedora 22 and released via official channels.
Comment 18 Fedora Update System 2016-02-02 11:13:22 EST
libreport-2.6.4-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-de4d7b3b1f
Comment 19 Fedora Update System 2016-02-03 18:26:13 EST
abrt-2.6.1-8.fc22, libreport-2.6.4-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-de4d7b3b1f
Comment 20 Fedora Update System 2016-02-04 19:21:07 EST
abrt-2.6.1-8.fc22, libreport-2.6.4-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.