Bug 1275783 - hammer cli does not complete uploading of larger docker images
hammer cli does not complete uploading of larger docker images
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management (Show other bugs)
6.0.4
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: David Davis
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 13:45 EDT by Partha Aji
Modified: 2016-04-22 11:54 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-07 07:44:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 11392 None None None 2016-04-22 11:54 EDT

  None (edit)
Description Partha Aji 2015-10-27 13:45:31 EDT
<pre>
# hammer repository upload-content --path rspec-puppet-el6.tar --id 56
Failed to upload file 'rspec-puppet-el6.tar' to repository. Please check the file and try again.

</pre>

I'm seeing almost no traffic when I do these (its there, but very low).  The first image was 571M, the second was 212M.

However with a 2.4M image....
<pre>
# hammer repository upload-content --path busybox.tar --id 56
Successfully uploaded file 'busybox.tar'.
</pre>

For that I saw network traffic immediately and continuously until it was up.
Comment 1 Partha Aji 2015-10-27 13:45:33 EDT
Created from redmine issue http://projects.theforeman.org/issues/11392
Comment 2 Partha Aji 2015-10-27 13:45:37 EDT
Upstream bug assigned to daviddavis@redhat.com
Comment 4 Bryan Kearney 2015-10-27 14:03:39 EDT
Upstream bug component is Container Management
Comment 5 Greg Swift 2015-10-27 15:48:16 EDT
fixing title here, since it was typo'd and not clear in the redmine instance
Comment 6 David Davis 2016-03-07 07:44:17 EST
Closing since pulp 2.8 no longer supports uploading of docker images.

Note You need to log in before you can comment on or make changes to this bug.