Bug 1190902 - hammer content upload slow
Summary: hammer content upload slow
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management
Version: 6.0.7
Hardware: x86_64
OS: Linux
medium
high vote
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: jcallaha
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks: sat61-release-notes 1315264 1316897
TreeView+ depends on / blocked
 
Reported: 2015-02-09 23:03 UTC by Dave Sullivan
Modified: 2020-01-17 15:29 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1315264 (view as bug list)
Environment:
Last Closed: 2016-09-27 09:01:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 11161 None None None Never
Red Hat Bugzilla 1275783 None CLOSED hammer cli does not complete uploading of larger docker images 2019-03-06 09:44:39 UTC
Red Hat Product Errata RHBA-2016:1938 normal SHIPPED_LIVE Satellite 6.1.10 bug fix update 2016-09-27 12:56:10 UTC

Internal Links: 1275783

Description Dave Sullivan 2015-02-09 23:03:42 UTC
Description of problem:

i was trying to upload packages to repository and i found it's very slow, also hammer process takes 100% of CPU. it doesnt show any progress, so cant realize if process got hung or it's still running without checking logs.

[root@lonlxt90001 apps]# time hammer -u admin -p changeme repository upload-content --path ./ --name unix_engineering --organization ACME --product Unix_Engineering

Successfully uploaded file 'nmr-sunjdk1601964-1.6.0_19_64-1.x86_64.rpm'.
Successfully uploaded file 'nmr-sunjdk1601764-1.6.0_17_64-1.x86_64.rpm'.

Successfully uploaded file 'nmr-netbackup-7.1-redhat-1.0-0.x86_64.rpm'.
Successfully uploaded file 'nmr-sunjdk16019-1.6.0_19-1.i386.rpm'.
Successfully uploaded file 'nmr-sunjdk16017-1.6.0_17-1.i386.rpm'.
Successfully uploaded file 'nmr-autosys-linux-4.5-2.i386.rpm'.

real    77m1.970s
user    58m34.944s
sys     5m50.962s
[root@lonlxt90001 apps]#


[root@lonlxt90001 apps]# ls -lh
total 677M
-rw-r--r--. 1 root root 2.4M Jan 23  2013 nmr-autosys-linux-4.5-2.i386.rpm
-rw-r--r--. 1 root root 301M Jan 27 06:33 nmr-netbackup-7.1-redhat-1.0-0.x86_64.rpm
-rw-r--r--. 1 root root  95M Jan 27 06:33 nmr-sunjdk16017-1.6.0_17-1.i386.rpm
-rw-r--r--. 1 root root  90M Jan 27 06:34 nmr-sunjdk1601764-1.6.0_17_64-1.x86_64.rpm
-rw-r--r--. 1 root root  98M Jan 27 06:34 nmr-sunjdk16019-1.6.0_19-1.i386.rpm
-rw-r--r--. 1 root root  92M Jan 27 06:34 nmr-sunjdk1601964-1.6.0_19_64-1.x86_64.rpm
[root@lonlxt90001 apps]#


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 8 Mike McCune 2015-07-20 16:22:49 UTC
Created redmine issue http://projects.theforeman.org/issues/11161 from this bug

Comment 15 Bryan Kearney 2016-02-26 21:08:23 UTC
Upstream bug component is Hammer

Comment 16 Bryan Kearney 2016-03-31 12:14:31 UTC
Upstream bug assigned to aruzicka@redhat.com

Comment 17 Bryan Kearney 2016-04-01 14:11:13 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/11161 has been closed
-------------
Adam Ruzicka
Applied in changeset commit:hammer-cli-katello|830fd6641fe7d4a82076780d18182f9949e4895c.

Comment 20 jcallaha 2016-09-19 19:11:28 UTC
Verified in Satellite 6.1.10. Content upload takes much less time. The below actions took approximately 14 minutes.

[root@rhsm-qe-1 isos]# for i in $(ls); do hammer -u admin -p changeme repository upload-content --path $i --id 35 --organization-id 1; done;
Successfully uploaded file 'Satellite-6.2.2-RHEL-6-20160919.0-Capsule-source-dvd1.iso'.
Successfully uploaded file 'Satellite-6.2.2-RHEL-6-20160919.0-Satellite-x86_64-dvd1.iso'.
Successfully uploaded file 'Satellite-6.2.2-RHEL-7-20160919.0-Capsule-source-dvd1.iso'.
Successfully uploaded file 'Satellite-6.2.2-RHEL-7-20160919.0-Satellite-source-dvd1.iso'.

[root@rhsm-qe-1 isos]# ls -lh
total 2.7G
-rw-r--r--. 1 root root 252M Sep 19 03:42 Satellite-6.2.2-RHEL-6-20160919.0-Capsule-source-dvd1.iso
-rw-r--r--. 1 root root 1.9G Sep 19 03:45 Satellite-6.2.2-RHEL-6-20160919.0-Satellite-x86_64-dvd1.iso
-rw-r--r--. 1 root root 257M Sep 19 03:51 Satellite-6.2.2-RHEL-7-20160919.0-Capsule-source-dvd1.iso
-rw-r--r--. 1 root root 320M Sep 19 03:52 Satellite-6.2.2-RHEL-7-20160919.0-Satellite-source-dvd1.iso

Comment 22 errata-xmlrpc 2016-09-27 09:01:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1938


Note You need to log in before you can comment on or make changes to this bug.