Bug 1275830 - [regression] tre.i686 and tre.x86_64 cannot be simultaneously installed.
[regression] tre.i686 and tre.x86_64 cannot be simultaneously installed.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tre (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dominik 'Rathann' Mierzejewski
Fedora Extras Quality Assurance
: Reopened
: 1352269 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 17:18 EDT by Hin-Tak Leung
Modified: 2016-11-19 16:11 EST (History)
4 users (show)

See Also:
Fixed In Version: tre-0.8.0-15.20140228gitc2f5d13.fc23 tre-0.8.0-18.20140228gitc2f5d13.fc24 tre-0.8.0-18.20140228gitc2f5d13.fc23 tre-0.8.0-18.20140228gitc2f5d13.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-14 16:01:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SPEC patch to create a tre-common package with platform-agnostic files (940 bytes, patch)
2016-07-20 08:34 EDT, joseba.gar
no flags Details | Diff

  None (edit)
Description Hin-Tak Leung 2015-10-27 17:18:16 EDT
Description of problem:
this seems to be a simple packaging error. During upgrading from f22 and f23, I got:

  file /usr/share/locale/fi/LC_MESSAGES/tre.mo conflicts between attempted installs of tre-0.8.0-14.20140228gitc2f5d13.fc23.i686 and tre-0.8.0-14
.20140228gitc2f5d13.fc23.x86_64
  file /usr/share/locale/sv/LC_MESSAGES/tre.mo conflicts between attempted installs of tre-0.8.0-14.20140228gitc2f5d13.fc23.i686 and tre-0.8.0-14
.20140228gitc2f5d13.fc23.x86_64


Version-Release number of selected component (if applicable):
tre-0.8.0-14.20140228gitc2f5d13.fc23.i686
tre-0.8.0-14.20140228gitc2f5d13.fc23.x86_64


How reproducible:
always

Steps to Reproduce:
1. have both of them in f22
2. try upgrading to f23
3.

Actual results:
conflict blocking upgrade.

Expected results:
upgrade successful.

Additional info:
The conflict does not look important so I forced update and let one overwrite the other anyway.
Comment 1 Fedora Update System 2016-01-05 11:46:48 EST
tre-0.8.0-15.20140228gitc2f5d13.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a88a7f88c
Comment 2 Fedora Update System 2016-01-05 19:28:27 EST
tre-0.8.0-15.20140228gitc2f5d13.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6a88a7f88c
Comment 3 Fedora Update System 2016-01-07 14:53:06 EST
tre-0.8.0-15.20140228gitc2f5d13.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 4 Dominik 'Rathann' Mierzejewski 2016-07-19 18:40:29 EDT
Looks like this wasn't fixed after all. :(
Comment 5 Dominik 'Rathann' Mierzejewski 2016-07-19 18:42:35 EDT
*** Bug 1352269 has been marked as a duplicate of this bug. ***
Comment 6 joseba.gar 2016-07-20 08:34 EDT
Created attachment 1182105 [details]
SPEC patch to create a tre-common package with platform-agnostic files

The attached patch for the SPEC file adds a tre-common-noarch package with the translation files, as well as AUTHORS, ChangeLog, LICENSE, NEWS, README, THANKS, TODO & docs.
If accepted, both tre.x86_64 & tre.i686 will depend on tre-common.

Creating RPM files from the patched SPEC results in x86_64 & i686 RPMs which can be installed simultaneously.

Side-effects of this patch:
  * The main RPMs only contain .so files (and soft links)
  * The path to the docs is changed from /usr/share/doc/tre to /usr/share/doc/tre-common

Please excuse if I'm missing something in the patch, but I'm not familiar with Fedora packaging policies.

Hope it helps.
Comment 7 joseba.gar 2016-07-20 10:07:50 EDT
I failed to mention that the patch is for the SPEC file in the SRPM file found here:
https://dl.fedoraproject.org/pub/fedora/linux/releases/24/Everything/source/tree/Packages/t/tre-0.8.0-16.20140228gitc2f5d13.fc24.src.rpm

Cheers,
Joseba

(In reply to joseba.gar from comment #6)
> Created attachment 1182105 [details]
> SPEC patch to create a tre-common package with platform-agnostic files
> 
> The attached patch for the SPEC file adds a tre-common-noarch package with
> the translation files, as well as AUTHORS, ChangeLog, LICENSE, NEWS, README,
> THANKS, TODO & docs.
> If accepted, both tre.x86_64 & tre.i686 will depend on tre-common.
> 
> Creating RPM files from the patched SPEC results in x86_64 & i686 RPMs which
> can be installed simultaneously.
> 
> Side-effects of this patch:
>   * The main RPMs only contain .so files (and soft links)
>   * The path to the docs is changed from /usr/share/doc/tre to
> /usr/share/doc/tre-common
> 
> Please excuse if I'm missing something in the patch, but I'm not familiar
> with Fedora packaging policies.
> 
> Hope it helps.
Comment 8 joseba.gar 2016-07-30 12:47:04 EDT
Any updates on this issue?

(In reply to joseba.gar from comment #7)
> I failed to mention that the patch is for the SPEC file in the SRPM file
> found here:
> https://dl.fedoraproject.org/pub/fedora/linux/releases/24/Everything/source/
> tree/Packages/t/tre-0.8.0-16.20140228gitc2f5d13.fc24.src.rpm
> 
> Cheers,
> Joseba
> 
> (In reply to joseba.gar from comment #6)
> > Created attachment 1182105 [details]
> > SPEC patch to create a tre-common package with platform-agnostic files
> > 
> > The attached patch for the SPEC file adds a tre-common-noarch package with
> > the translation files, as well as AUTHORS, ChangeLog, LICENSE, NEWS, README,
> > THANKS, TODO & docs.
> > If accepted, both tre.x86_64 & tre.i686 will depend on tre-common.
> > 
> > Creating RPM files from the patched SPEC results in x86_64 & i686 RPMs which
> > can be installed simultaneously.
> > 
> > Side-effects of this patch:
> >   * The main RPMs only contain .so files (and soft links)
> >   * The path to the docs is changed from /usr/share/doc/tre to
> > /usr/share/doc/tre-common
> > 
> > Please excuse if I'm missing something in the patch, but I'm not familiar
> > with Fedora packaging policies.
> > 
> > Hope it helps.
Comment 9 Dominik 'Rathann' Mierzejewski 2016-08-19 08:57:04 EDT
I was on vacation. Thanks for the patch. I'll probably take a second look at this sometime next week.
Comment 10 joseba.gar 2016-08-19 09:19:27 EDT
(In reply to Dominik 'Rathann' Mierzejewski from comment #9)
> I was on vacation. Thanks for the patch. I'll probably take a second look at
> this sometime next week.

Sorry for the spam.

I'll be happy to help in case there's something else I can do.

Regards,
Joseba
Comment 11 joseba.gar 2016-10-26 08:44:52 EDT
(In reply to Dominik 'Rathann' Mierzejewski from comment #9)
> I was on vacation. Thanks for the patch. I'll probably take a second look at
> this sometime next week.

Good evening,

Have you had time to look into this? I wouldn't like it to slip into Fedora 25. Please let me know if there is something I can do to help.

Kind regards,
Joseba
Comment 12 Fedora Update System 2016-11-04 06:14:48 EDT
tre-0.8.0-18.20140228gitc2f5d13.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0ff6c3d84b
Comment 13 Fedora Update System 2016-11-04 06:15:02 EDT
tre-0.8.0-18.20140228gitc2f5d13.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0a952a3bc0
Comment 14 Fedora Update System 2016-11-04 06:15:12 EDT
tre-0.8.0-18.20140228gitc2f5d13.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd09eab674
Comment 15 joseba.gar 2016-11-04 10:03:30 EDT
Manually installing the updated packages seems to be working fine. Thanks a lot!

Joseba
Comment 16 Fedora Update System 2016-11-04 23:35:52 EDT
tre-0.8.0-18.20140228gitc2f5d13.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cd09eab674
Comment 17 Fedora Update System 2016-11-04 23:54:55 EDT
tre-0.8.0-18.20140228gitc2f5d13.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0ff6c3d84b
Comment 18 Fedora Update System 2016-11-05 15:00:27 EDT
tre-0.8.0-18.20140228gitc2f5d13.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0a952a3bc0
Comment 19 Fedora Update System 2016-11-05 21:53:42 EDT
tre-0.8.0-18.20140228gitc2f5d13.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0ff6c3d84b
Comment 20 Fedora Update System 2016-11-14 16:01:12 EST
tre-0.8.0-18.20140228gitc2f5d13.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 21 Fedora Update System 2016-11-14 18:51:44 EST
tre-0.8.0-18.20140228gitc2f5d13.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2016-11-19 16:11:41 EST
tre-0.8.0-18.20140228gitc2f5d13.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.