Bug 127584 - logrotate generates errors due to missing log file
Summary: logrotate generates errors due to missing log file
Status: CLOSED DUPLICATE of bug 122911
Alias: None
Product: Fedora
Classification: Fedora
Component: ppp (Show other bugs)
(Show other bugs)
Version: 2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-09 21:19 UTC by John Dennis
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Dennis 2004-07-09 21:19:24 UTC
This is for ppp-2.4.2-2

The logrotate config file (/etc/logrotate.d/ppp) attempts to rotate
the log file /var/log/ppp/connect-errors. However, the log file is not
present, this generates logrotate errors.

Since I'm not familar with the mechanics of the ppp package I'm not
sure if this log file is always expected to exist or not. If on the
assumption it is O.K. for this log file to be missing then the
logrotate config file for ppp needs include the "missingok" flag so
that the absense of this file does not generate errors.

If the log file is always supposed to be there (dosen't sound like it
should) then the problem is elsewhere.

The verbose error coming from logrotate is:
error: stat of /var/log/ppp/connect-errors failed: No such file or
directory

Comment 1 William Hooper 2004-07-09 22:23:12 UTC
Duplicate of Bug 122911

Comment 2 Miloslav Trmac 2004-07-11 13:37:18 UTC

*** This bug has been marked as a duplicate of 122911 ***

Comment 3 Red Hat Bugzilla 2006-02-21 19:04:23 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.