Bug 1276018 - Wrong value of snap-max-hard-limit observed in 'gluster volume info'.
Wrong value of snap-max-hard-limit observed in 'gluster volume info'.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Avra Sengupta
:
Depends On: 1275521
Blocks: 1277394
  Show dependency treegraph
 
Reported: 2015-10-28 08:16 EDT by Avra Sengupta
Modified: 2016-06-16 09:41 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1275521
: 1277394 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:41:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-10-28 08:18:23 EDT
REVIEW: http://review.gluster.org/12443 (snapshot: Don't display snapshot's hard-limit and soft-limit in vol info) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Vijay Bellur 2015-11-03 01:34:41 EST
COMMIT: http://review.gluster.org/12443 committed in master by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 2e56bde3ea952beabd27cdf8a3a10da563a00bcc
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Wed Oct 28 15:18:07 2015 +0530

    snapshot: Don't display snapshot's hard-limit and soft-limit in vol info
    
    The snap-max-hard-limit being displayed in the volume info
    currently is propagated from system's snap-max-hard-limit as
    that is a global option common for all volumes, and hence ends
    up showing the system's snap-max-hard-limit.
    
    We should not be displaying snap-max-hard-limit and
    snap-max-soft-limit in the volume info at all, as these are
    snap config options and should be set and displayed via snap
    config command.
    
    Modified bug-1113476.t to test the same behaviour.
    
    Change-Id: I90891f0cf7fb39fd686787297c7f7cd8c1e7daa1
    BUG: 1276018
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/12443
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 3 Niels de Vos 2016-06-16 09:41:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.