Bug 1276023 - Clone creation should not be successful when the node participating in volume goes down.
Clone creation should not be successful when the node participating in volume...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
mainline
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Avra Sengupta
:
Depends On: 1275633
Blocks: 1288030
  Show dependency treegraph
 
Reported: 2015-10-28 08:21 EDT by Avra Sengupta
Modified: 2016-06-16 09:41 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1275633
: 1288030 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:41:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-02 07:35:43 EST
REVIEW: http://review.gluster.org/12490 (snapshot: Fix quorum check for clone) posted (#1) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 2 Vijay Bellur 2015-11-20 06:06:39 EST
REVIEW: http://review.gluster.org/12490 (snapshot: Fix quorum check for clone) posted (#2) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 3 Vijay Bellur 2015-11-23 04:01:38 EST
REVIEW: http://review.gluster.org/12490 (snapshot: Fix quorum check for clone) posted (#3) for review on master by Avra Sengupta (asengupt@redhat.com)
Comment 4 Vijay Bellur 2015-12-02 10:36:10 EST
COMMIT: http://review.gluster.org/12490 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit cb7da0ffba147173bc9e6cd05f0a88a2c1ac9cdc
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Mon Nov 2 17:49:44 2015 +0530

    snapshot: Fix quorum check for clone
    
    snapshot clone was not performing quorum check
    and was just relying on glusterd server quorum.
    
    Wrote glusterd_snap_quorum_check_for_clone(), to
    perform the same. Also moved common quorum check code
    from glusterd_snap_quorum_check_for_create(), to
    glusterd_snap_common_quorum_chk_clone_create() to be
    shared by both
    
    Change-Id: Ib78c709186841780876de8ef7d7c9243b7f67995
    BUG: 1276023
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/12490
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
Comment 5 Niels de Vos 2016-06-16 09:41:47 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.