Bug 1288030 - Clone creation should not be successful when the node participating in volume goes down.
Clone creation should not be successful when the node participating in volume...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: snapshot (Show other bugs)
3.7.6
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Avra Sengupta
:
Depends On: 1275633 1276023
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-03 05:49 EST by Avra Sengupta
Modified: 2016-04-19 03:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1276023
Environment:
Last Closed: 2016-02-15 04:15:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-03 05:51:16 EST
REVIEW: http://review.gluster.org/12869 (snapshot: Fix quorum check for clone) posted (#1) for review on release-3.7 by Avra Sengupta (asengupt@redhat.com)
Comment 2 Vijay Bellur 2015-12-04 02:14:36 EST
COMMIT: http://review.gluster.org/12869 committed in release-3.7 by Rajesh Joseph (rjoseph@redhat.com) 
------
commit 8eccbbb41622fd739059403b9334cc316d8dc9af
Author: Avra Sengupta <asengupt@redhat.com>
Date:   Mon Nov 2 17:49:44 2015 +0530

    snapshot: Fix quorum check for clone
    
        Backport of http://review.gluster.org/#/c/12490/
    
    snapshot clone was not performing quorum check
    and was just relying on glusterd server quorum.
    
    Wrote glusterd_snap_quorum_check_for_clone(), to
    perform the same. Also moved common quorum check code
    from glusterd_snap_quorum_check_for_create(), to
    glusterd_snap_common_quorum_chk_clone_create() to be
    shared by both
    
    Change-Id: Ib78c709186841780876de8ef7d7c9243b7f67995
    BUG: 1288030
    Signed-off-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-on: http://review.gluster.org/12490
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    (cherry picked from commit cb7da0ffba147173bc9e6cd05f0a88a2c1ac9cdc)
    Reviewed-on: http://review.gluster.org/12869
    Reviewed-by: mohammed rafi  kc <rkavunga@redhat.com>
Comment 3 Kaushal 2016-04-19 03:50:07 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.