Bug 1276192 - Reduce transaction isolation level for profile_search table
Reduce transaction isolation level for profile_search table
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Database (Show other bugs)
4.4
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: Matt Tyson
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-28 23:08 EDT by Matt Tyson
Modified: 2015-11-26 01:53 EST (History)
5 users (show)

See Also:
Fixed In Version: 4.4.10044.10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-15 19:42:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Tyson 2015-10-28 23:08:11 EDT
The profile_search table stores recently used searches by the user.

When the user starts opening searches in quick succession, this can cause postgres serialization errors to happen.

These serialization errors really aren't all that critical for this table and could be safely ignored.

In Bugzilla/Search/Recent.pm we should wind the serialization level back to READ COMMITTED where it deletes from the profile_search table.
Comment 3 Rony Gong 2015-11-12 03:58:57 EST
Test this on build 4.4.10042-7
Before upgrading, QE could get the serialization error when open huge amount tabs of search at once:
Red Hat Bugzilla's database reported a query serialization error. Most likely this occurred because another user or process attempted to change the same data that you were attempting to change. 

Please press Back and retry the transaction.

After upgrading, QE couldn't find the serialization error happened anymore.
Comment 4 Matt Tyson 2015-11-15 19:42:23 EST
This change is now live. If there are any issues, do not reopen this bug.
Instead, you should create a new bug and reference this bug.

Note You need to log in before you can comment on or make changes to this bug.