Bug 1276241 - virt-who show "RestlibException: undefined method `inject' for nil:NilClass" when unregister rhevh to satellite
virt-who show "RestlibException: undefined method `inject' for nil:NilClass" ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Other (Show other bugs)
6.0.0
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
: 1252338 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-29 04:30 EDT by Liushihui
Modified: 2017-09-19 13 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:52:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Liushihui 2015-10-29 04:30:55 EDT
Description of problem:
when virt-who run at rhevm mode, unregister rhevh to satellite, virt-who will show "RestlibException: undefined method `inject' for nil:NilClass" in the process of reloading.

Version-Release number of selected component (if applicable):
subscription-manager-1.15.9-14.el7.x86_64
python-rhsm-1.15.4-5.el7.x86_64
virt-who-0.14-9.el7.noarch
vdsm-4.17.8-1.el7ev.noarch
Satellite-6.1.0-RHEL-7-20151027.0

How reproducible:
Always

Steps to Reproduce:
1. Register rhevh to satellite6.1, configure virt-who run at rhevm mode
[root@hp-z220-06 ~]# cat /etc/sysconfig/virt-who  | grep -v ^# | grep -v ^$
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=5
VIRTWHO_RHEVM=1
VIRTWHO_RHEVM_OWNER=Default_Organization
VIRTWHO_RHEVM_ENV=Library
VIRTWHO_RHEVM_SERVER=https://10.66.79.8:443
VIRTWHO_RHEVM_USERNAME=admin@internal
VIRTWHO_RHEVM_PASSWORD=redhat
2. Start virt-who service, virt-who send h/g mapping to satellite
3. Unregister rhevh, then check virt-who's log
[root@hp-z220-06 ~]# subscription-manager  unregister
System has been unregistered.
[root@hp-z220-06 ~]# tail -f /var/log/rhsm/rhsm.log
2015-10-29 08:26:25,695 [WARNING]  @virtwho.py:357 - virt-who reload
2015-10-29 08:26:25,695 [DEBUG] subscription-manager:20497 @utils.py:284 - Restarted virt-who
2015-10-29 08:26:28,150 [ERROR]  @subscriptionmanager.py:171 - Communication with server failed:
Traceback (most recent call last):
  File "/usr/share/virt-who/manager/subscriptionmanager/subscriptionmanager.py", line 167, in hypervisorCheckIn
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 903, in hypervisorCheckIn
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 647, in request_post
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 564, in _request
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 611, in validateResponse
RestlibException: undefined method `inject' for nil:NilClass
2015-10-29 08:26:28,150 [ERROR]  @virtwho.py:177 - Unable to send data: Communication with subscription manager failed with code 500: undefined method `inject' for nil:NilClass

Actual results:
It will show "RestlibException" when virt-who communicate with subscription manager.

Expected results:
vit-who shouldn't show "RestlibException" when communicate with subscription manager 

Additional info:
If virt-who run at vdsm mode, it hasn't this problem when unregister rhevh.
Comment 2 Radek Novacek 2015-11-03 02:40:23 EST
Restlib exception suggest that is error is a server side issue. I'll switch this to the candlepin for investigation.

Any ideas what could cause this exception?
Comment 3 Barnaby Court 2016-03-01 16:33:11 EST
This appears to be an error in the katello proxy between virt-who and candlepin. See the error about "nil:NilClass" in the description.
Comment 5 Bryan Kearney 2016-05-26 11:30:35 EDT
*** Bug 1252338 has been marked as a duplicate of this bug. ***
Comment 7 Bryan Kearney 2016-07-26 11:25:24 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 8 Bryan Kearney 2016-07-26 11:39:15 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 10 Eko 2016-07-27 01:42:59 EDT
verified with Satellite-6.2.0-RHEL-7-20160725.0

to rhevm mode, after unregister virt-who host, it will show following info as expected:
SubscriptionManagerUnregisteredError: Unable to read certificate, system is not registered or you are not root
Comment 11 Bryan Kearney 2016-07-27 07:52:15 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.