Bug 127627 - Apparent typo in /etc/init.d/pcmcia prevents modules unloading, hence laptop suspend
Apparent typo in /etc/init.d/pcmcia prevents modules unloading, hence laptop ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
: 127774 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-11 11:10 EDT by James Turner
Modified: 2015-01-04 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-11 14:57:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Turner 2004-07-11 11:10:49 EDT
Description of problem:

When executing "/etc/init.d/pcmcia stop", the yenta_socket (etc.) 
module does not get unloaded, apparently due to a typo. My IBM T22 
laptop won't go into suspend with this module loaded, so I have to 
do "rmmod yenta_socket" manually as root before suspend will work, 
even though I listed pcmcia as a service to be restarted by apmd 
in /etc/sysconfig/apmd.

The problem is in the statement:

  if grep -q "ds  " /proc/modules ; then

The grep never matches because there are 2 spaces after "ds", whereas 
there is only one space after "ds" in /proc/modules.

If I edit the pcmcia script to remove the extra space from the
first grep argument (ie. "ds "), then "/etc/init.d/pcmcia stop" now 
works correctly and my laptop is put into suspend automatically by 
apmd when I close the lid.

(By the way, ACPI suspend doesn't work for me on this machine)


Version-Release number of selected component (if applicable):

initscripts-7.53-1

How reproducible:
Every time

Steps to Reproduce:
1. su
2. /etc/init.d/pcmcia stop
3. /sbin/lsmod
  
Actual results:
The modules "yenta_socket" and "ds" are still loaded.

Expected results:
The modules should have been unloaded.

Additional info:
I'm running Fedora Core 2 final with kernel 2.6.5 on an IBM Thinkpad 
T22 laptop with a Pentium III processor (just in case 
the /proc/modules format varies between kernels or systems...).
Comment 1 Bill Nottingham 2004-09-08 01:35:15 EDT
*** Bug 127774 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2004-09-08 02:11:56 EDT
Please try pcmcia-cs-3.2.7-1.8.2.1 in FC2 test updates.
Comment 3 James Turner 2004-10-11 13:14:32 EDT
Thanks for the fix. Unfortunately my laptop's motherboard died just
days before your reply(!), so I can't try out the update on the
original computer... The problem should be generic enough to test on
another machine though(?) - when my new T42 laptop arrives, I'll
install FC3 and check that it's now OK.
Comment 4 Bill Nottingham 2004-10-11 14:57:01 EDT
Closing as fixed in the update.

Note You need to log in before you can comment on or make changes to this bug.