Bug 1276597 - Failed to register rhevh7.2 to satellite6.1.0 with TUI since the configure info hasn't been saved
Failed to register rhevh7.2 to satellite6.1.0 with TUI since the configure in...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.0
x86_64 Linux
high Severity high
: ovirt-3.6.1
: 3.6.0
Assigned To: Ryan Barry
wanghui
:
: 1280217 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 05:16 EDT by Liushihui
Modified: 2016-07-03 20:39 EDT (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-3.6.0-0.24.20151209gitc0fa931.el7ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:42:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
TUI configure (81.86 KB, image/png)
2015-10-30 05:19 EDT, Liushihui
no flags Details
TUI-register error (64.94 KB, image/png)
2015-10-30 05:19 EDT, Liushihui
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 49521 master MERGED Call ConfigurureSubscriptionManager in rhn_model Never
oVirt gerrit 50185 ovirt-3.6 MERGED Call ConfigurureSubscriptionManager in rhn_model Never

  None (edit)
Description Liushihui 2015-10-30 05:16:05 EDT
Description of problem:
RHN Registration info in TUI hasn't been saved when register rhevh7.2 to satellite6.1.0 with TUI

Version-Release number of selected component (if applicable):
rhev-hypervisor7-7.2-20151009.0 
subscription-manager-1.15.9-14.el7.x86_64
python-rhsm-1.15.4-5.el7.x86_64
vdsm-4.17.8-1.el7ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Login to rhevh TUI .
2. Go to "RHN Registration" page,input the info as the following, then "save" it, please see the screeshot in attachment
Login: admin
Password: admin
Type : Satellite
URL: https://hp-dl2x170g6-01.rhts.eng.bos.redhat.com/rhsm
CA URL: http://10.66.100.116/projects/sam-virtwho/sam_ca/katello-server-ca.pem
Organization: Default_Organization
3. Check the output in TUI,it will show
"An error occurred while applying the changes
Registration Failed". Please see the screenshot in attachment.
4. Check the rhsm log in /var/log/rhsm/rhsm.log
2015-10-29 06:06:29,044 [ERROR] subscription-manager:22116 @managercli.py:1080 - Invalid username or password. To create a login, please visit https://www.redhat.com/wapps/ugc/register.html
Traceback (most recent call last):
  File "/usr/share/rhsm/subscription_manager/managercli.py", line 1075, in _do_command
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 876, in registerConsumer
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 647, in request_post
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 564, in _request
  File "/usr/lib64/python2.7/site-packages/rhsm/connection.py", line 611, in validateResponse
RestlibException: Invalid username or password. To create a login, please visit https://www.redhat.com/wapps/ugc/register.html
5. Check the configure file /etc/rhsm/rhsm.conf
[root@hp-z220-05 admin]# cat /etc/rhsm/rhsm.conf  | grep -v ^# | grep -v ^$
[server]
hostname = subscription.rhn.redhat.com  ====> It hasn't been updated
prefix = /subscription                  ====> It hasn't been updated
port = 443
insecure = 0
ssl_verify_depth = 3
proxy_hostname =
proxy_port =
proxy_user =
proxy_password =
[rhsm]
baseurl= https://cdn.redhat.com        ====> It hasn't been updated
ca_cert_dir = /etc/rhsm/ca/
repo_ca_cert = %(ca_cert_dir)sredhat-uep.pem  ====> It hasn't been updated
productCertDir = /etc/pki/product
entitlementCertDir = /etc/pki/entitlement
consumerCertDir = /etc/pki/consumer
manage_repos = 1
full_refresh_on_yum = 0
report_package_profile = 1
pluginDir = /usr/share/rhsm-plugins
pluginConfDir = /etc/rhsm/pluginconf.d
[rhsmcertd]
certCheckInterval = 240
autoAttachInterval = 1440

Actual results:
Failed to register rhevh 7.2 to satellite in TUI since configure info hasn't been saved. 

Expected results:
During register rhevh7.2 on TUI, some configure info in rhsm.conf should be modified as the following:
hostname=[Satellite hostname]
prefix = /rhsm
baseurl= https://[Satellite hostname]/pulp/repos
repo_ca_cert = %(ca_cert_dir)skatello-server-ca.pem

Additional info:
Comment 1 Liushihui 2015-10-30 05:19 EDT
Created attachment 1087885 [details]
TUI configure
Comment 2 Liushihui 2015-10-30 05:19 EDT
Created attachment 1087886 [details]
TUI-register error
Comment 4 Liushihui 2015-11-05 02:19:33 EST
It hasn't this problem on Rhev-hypervisor7-7.2-20151019.2. when add Rhev-hypervisor7-7.2-20151019.2 to rhevm3.5.5, register this rhevh to satellite successfully.

Version:
vdsm-4.16.27-1.el7ev.x86_64
rhevm-3.5.5-0.1.el6ev.noarch.rpm
Comment 6 Fabian Deutsch 2015-12-09 10:19:00 EST
*** Bug 1280217 has been marked as a duplicate of this bug. ***
Comment 8 wanghui 2015-12-28 21:56:59 EST
Test version:
RHEV-H 7.2-20151221.1.el7ev
ovirt-node-3.6.0-0.24.20151209gitc0fa931.el7ev.noarch

Red Hat Satellite Version 6.1.5

Test steps:
1. Clean install RHEV-H 7.2-20151221.1.el7ev
2. Enable network
3. Register to satellite 6.1.5

Test result:
1. RHEVH can be registered succeed.

This issue is fixed in ovirt-node-3.6.0-0.24.20151209gitc0fa931.el7ev.noarch. Change the status to verified.
Comment 10 errata-xmlrpc 2016-03-09 09:42:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.