Bug 1276643 - Upgrading a subset of cluster to 3.7.5 leads to issues with glusterd commands
Upgrading a subset of cluster to 3.7.5 leads to issues with glusterd commands
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Satish Mohan
:
Depends On: 1276029
Blocks: 1277791
  Show dependency treegraph
 
Reported: 2015-10-30 07:03 EDT by Gaurav Kumar Garg
Modified: 2016-06-16 09:42 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1276029
: 1277791 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:42:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaurav Kumar Garg 2015-10-30 07:03:32 EDT
+++ This bug was initially created as a clone of Bug #1276029 +++

This is extract from mail that a user(David Robinson) sent on gluster-users.

Description of problem:

I have a replica pair setup that I was trying to upgrade from 3.7.4 to 3.7.5. 
After upgrading the rpm packages (rpm -Uvh *.rpm) and rebooting one of the nodes, I am now receiving the following:
 
[root@frick01 log]# gluster volume status
Staging failed on frackib01.corvidtec.com. Please check log file for details.
 

[root@frick01 log]# gluster volume info
 
Volume Name: gfs
Type: Replicate
Volume ID: abc63b5c-bed7-4e3d-9057-00930a2d85d3
Status: Started
Number of Bricks: 1 x 2 = 2
Transport-type: tcp,rdma
Bricks:
Brick1: frickib01.corvidtec.com:/data/brick01/gfs
Brick2: frackib01.corvidtec.com:/data/brick01/gfs
Options Reconfigured:
storage.owner-gid: 100
server.allow-insecure: on
performance.readdir-ahead: on
server.event-threads: 4
client.event-threads: 4

How reproducible:
Reported by multiple users.

Logs have been attached.

--- Additional comment from Raghavendra Talur on 2015-10-28 08:47 EDT ---
Comment 1 Vijay Bellur 2015-10-30 07:25:29 EDT
REVIEW: http://review.gluster.org/12473 (glusterd: move new feature (tiering) enum op to the last of the array) posted (#1) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 2 Vijay Bellur 2015-11-02 01:54:01 EST
REVIEW: http://review.gluster.org/12473 (glusterd: move new feature (tiering) enum op to the last of the array) posted (#2) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 3 Vijay Bellur 2015-11-02 05:28:36 EST
REVIEW: http://review.gluster.org/12473 (glusterd: move new feature (tiering) enum op to the last of the array) posted (#3) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 4 Vijay Bellur 2015-11-02 08:01:31 EST
REVIEW: http://review.gluster.org/12473 (glusterd: move new feature (tiering) enum op to the last of the array) posted (#4) for review on master by Gaurav Kumar Garg (ggarg@redhat.com)
Comment 5 Vijay Bellur 2015-11-03 00:56:58 EST
REVIEW: http://review.gluster.org/12473 (glusterd: move new feature (tiering) enum op to the last of the array) posted (#5) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 8 Niels de Vos 2016-06-16 09:42:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.