Bug 1276660 - Wildcard patterns in command arguments not expanded
Wildcard patterns in command arguments not expanded
Status: CLOSED DUPLICATE of bug 1195083
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: sos (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Pavel Moravec
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 08:08 EDT by Martin Frodl
Modified: 2016-01-07 06:53 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1276652
Environment:
Last Closed: 2016-01-07 06:53:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Frodl 2015-10-30 08:08:04 EDT
+++ This bug was initially created as a clone of Bug #1276652 +++

Description of problem:

Some plugins collect the output of commands with paths containing a wildcard expression in their arguments. These wildcards are never expanded.

For instance, ipa plugin collects the output of the following command:

    ls -la /etc/dirsrv/slapd-*/schema

Having created a sample directory matching this pattern, the actual output of the ls command is:

# ls -la /etc/dirsrv/slapd-*/schema/
total 8
drwxr-xr-x. 2 root root 4096 Oct 30 07:07 .
drwxr-xr-x. 3 root root 4096 Oct 30 07:07 ..

What sosreport collects, however, looks like this:

# cat sosreport-blabla/sos_commands/ipa/ls_-la_.etc.dirsrv.slapd-_.schema
ls: cannot access /etc/dirsrv/slapd-*/schema/: No such file or directory

There are other plugins affected by this bug, so far I know about md and smartcard.

This bug was not present sos-2.2-68.el6.noarch.

Version-Release number of selected component (if applicable):
sos-3.2-35.el7.noarch
Comment 2 David Kutálek 2016-01-07 06:53:32 EST
Looks like this was already reported before.

*** This bug has been marked as a duplicate of bug 1195083 ***

Note You need to log in before you can comment on or make changes to this bug.