Bug 1276789 - No 'check all' check box on tasks page
No 'check all' check box on tasks page
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity low
: GA
: 5.6.0
Assigned To: Martin Hradil
Nandini Chandra
ui:task
:
Depends On:
Blocks: 1289245
  Show dependency treegraph
 
Reported: 2015-10-30 19:11 EDT by Nandini Chandra
Modified: 2016-06-29 11:01 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1289245 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:01:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of tasks page (113.29 KB, image/png)
2015-10-30 19:11 EDT, Nandini Chandra
no flags Details

  None (edit)
Description Nandini Chandra 2015-10-30 19:11:29 EDT
Created attachment 1088057 [details]
screen shot of tasks page

Description of problem:
------------------------


Version-Release number of selected component (if applicable):
-----------------------
5.5.0.8


How reproducible:
-----------------
Always


Steps to Reproduce:
-------------------
1.Navigate to the Configuration->Tasks page.


Actual results:
---------------
No 'check all' check box on tasks page.See attached screen shot.


Expected results:
-----------------
The tasks page should have a 'check all' check box.


Additional info:
----------------
Comment 6 CFME Bot 2015-12-02 14:44:33 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/b48b4eb967d86d782b331a5e3814bf86e905825a

commit b48b4eb967d86d782b331a5e3814bf86e905825a
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Mon Nov 23 19:34:03 2015 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Thu Nov 26 13:55:32 2015 +0000

    layout_uses_paging? - new _content branch for layouts without listnav but with paging
    
    currently only used in Configure > Tasks
    
    it's the original else branch, with paging_controls .row added
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1276789

 app/helpers/application_helper/page_layouts.rb | 10 +++++++++
 app/views/layouts/_content.html.haml           | 31 ++++++++++++++++++++++++++
 2 files changed, 41 insertions(+)
Comment 7 CFME Bot 2015-12-02 14:44:39 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/b2b4bd496ad42fc9a0e7e2436df7892678709f6b

commit b2b4bd496ad42fc9a0e7e2436df7892678709f6b
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Tue Nov 24 15:36:28 2015 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Thu Nov 26 13:55:32 2015 +0000

    MiqTaskController#jobs - replace paging controls on param change
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1276789

 app/controllers/miq_task_controller.rb | 1 +
 1 file changed, 1 insertion(+)
Comment 8 CFME Bot 2015-12-02 14:44:44 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/85b13dc2352fb0360125784a107ab0f23f46116e

commit 85b13dc2352fb0360125784a107ab0f23f46116e
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Thu Nov 26 15:29:31 2015 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Thu Nov 26 15:29:31 2015 +0000

    MiqTaskController - fix @lastaction to "jobs"
    
    @lastaction is used to generate various urls, so must be a valid action
    none of ui_jobs, all_jobs and all_ui_jobs are..
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1276789

 app/controllers/miq_task_controller.rb | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)
Comment 9 CFME Bot 2015-12-02 14:44:50 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/fbd93314078e0b22e360baf373ee6a8146db8d2e

commit fbd93314078e0b22e360baf373ee6a8146db8d2e
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Thu Nov 26 15:37:54 2015 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Thu Nov 26 15:37:54 2015 +0000

    MiqTaskController - replace pc_div_1 also when replacing main_div
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1276789

 app/controllers/miq_task_controller.rb | 2 ++
 1 file changed, 2 insertions(+)
Comment 10 CFME Bot 2015-12-07 16:04:11 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=bb2cf1616e51f19418590b6e383373d14a3ed6f6

commit bb2cf1616e51f19418590b6e383373d14a3ed6f6
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Mon Nov 23 19:34:03 2015 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Mon Nov 30 16:11:59 2015 +0000

    layout_uses_paging? - new _content branch for layouts without listnav but with paging
    
    currently only used in Configure > Tasks
    
    it's the original else branch, with paging_controls .row added
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1276789
    (cherry picked from commit b48b4eb967d86d782b331a5e3814bf86e905825a)

 app/helpers/application_helper/page_layouts.rb | 10 +++++++++
 app/views/layouts/_content.html.haml           | 31 ++++++++++++++++++++++++++
 2 files changed, 41 insertions(+)
Comment 11 CFME Bot 2015-12-07 16:04:17 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=5568a4186a3f68009ad45f741dfc0b39ede43491

commit 5568a4186a3f68009ad45f741dfc0b39ede43491
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Tue Nov 24 15:36:28 2015 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Mon Nov 30 16:11:59 2015 +0000

    MiqTaskController#jobs - replace paging controls on param change
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1276789
    (cherry picked from commit b2b4bd496ad42fc9a0e7e2436df7892678709f6b)

 app/controllers/miq_task_controller.rb | 1 +
 1 file changed, 1 insertion(+)
Comment 12 CFME Bot 2015-12-07 16:04:23 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=377b74bc80b85722acd7a2dc32b0a81d0f3597ae

commit 377b74bc80b85722acd7a2dc32b0a81d0f3597ae
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Thu Nov 26 15:29:31 2015 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Mon Nov 30 16:11:59 2015 +0000

    MiqTaskController - fix @lastaction to "jobs"
    
    @lastaction is used to generate various urls, so must be a valid action
    none of ui_jobs, all_jobs and all_ui_jobs are..
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1276789
    (cherry picked from commit 85b13dc2352fb0360125784a107ab0f23f46116e)

 app/controllers/miq_task_controller.rb | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)
Comment 13 CFME Bot 2015-12-07 16:04:28 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=16d50779e9d4963a290437150c741fed2463d6b2

commit 16d50779e9d4963a290437150c741fed2463d6b2
Author:     Martin Hradil <mhradil@redhat.com>
AuthorDate: Thu Nov 26 15:37:54 2015 +0000
Commit:     Martin Hradil <mhradil@redhat.com>
CommitDate: Mon Nov 30 16:11:59 2015 +0000

    MiqTaskController - replace pc_div_1 also when replacing main_div
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1276789
    (cherry picked from commit fbd93314078e0b22e360baf373ee6a8146db8d2e)

 app/controllers/miq_task_controller.rb | 2 ++
 1 file changed, 2 insertions(+)
Comment 14 CFME Bot 2015-12-07 16:04:33 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=f8e9c04a7d63a52eeeed402fc48c7e560a8ba194

commit f8e9c04a7d63a52eeeed402fc48c7e560a8ba194
Merge: 9632686 16d5077
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Mon Dec 7 16:03:35 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Mon Dec 7 16:03:35 2015 -0500

    Merge branch 'bz1276789-check-all-tasks-55' into '5.5.z'
    
    Fix missing check all (paging controls) in Configure > Tasks
    
    This introduces a new _content layout variant which has no listnav but has paging controls - controlled by (new) `layout_uses_paging?` and adds a page.replace for pagingcontrols on update.
    
    \+ various cleanup and refactors in related code:
       * `miqAjaxAuth` (js) is only ever called without args, removed unused logic
       * `auth_error` is only used on `DashboardController`, moved there from `ApplicationController`
       * `ApplicationControlller#replace_gtl_main_div` - condition around listnav replacement looked suspiciously like `layout_uses_listnav?`, using that now
       * `MiqTaskController` would do some feature checks twice in a row, fixed
       * `layout_uses_listnav?` had a complex condition - split up
       * replaced all layout=dashboard & action=show|change_tab|auth_error conditions with a new helper (`dashboard_no_listnav?`)
       * removed commented out code from _content layout template
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1276789
    
    5.5 BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1289245
    
    https://github.com/ManageIQ/manageiq/pull/5575
    clean cherry pick
    
    See merge request !551

 app/assets/javascripts/miq_application.js      | 25 +++-------
 app/controllers/application_controller.rb      | 15 +-----
 app/controllers/dashboard_controller.rb        |  6 +++
 app/controllers/miq_task_controller.rb         | 26 +++++-----
 app/helpers/application_helper/page_layouts.rb | 69 ++++++++++++++++++++------
 app/views/layouts/_content.html.haml           | 31 ++++++------
 6 files changed, 95 insertions(+), 77 deletions(-)
Comment 15 Nandini Chandra 2016-04-19 15:21:49 EDT
Verified in 5.6.0.1-beta2.20160413141124_e25ac0e
Comment 17 errata-xmlrpc 2016-06-29 11:01:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.