Bug 1276806 - python-matplotlib-1.5.1 is available
python-matplotlib-1.5.1 is available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-matplotlib (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Spura
Fedora Extras Quality Assurance
: FutureFeature, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-30 20:24 EDT by Upstream Release Monitoring
Modified: 2016-05-07 08:11 EDT (History)
8 users (show)

See Also:
Fixed In Version: python-matplotlib-1.5.1-3.fc24
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-07 08:11:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Upstream Release Monitoring 2015-10-30 20:24:08 EDT
Latest upstream release: 1.5.0
Current version/release in rawhide: 1.4.3-6.fc23
URL: https://pypi.python.org/pypi/matplotlib

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 1 Upstream Release Monitoring 2015-10-30 20:24:29 EDT
Failed to kick off scratch build.

list index out of range
Comment 2 Upstream Release Monitoring 2016-01-11 07:13:44 EST
Latest upstream release: 1.5.1
Current version/release in rawhide: 1.2.0-15.el7
URL: https://pypi.python.org/pypi/matplotlib

Please consult the package updates policy before you issue an update to a stable branch: https://fedoraproject.org/wiki/Updates_Policy

More information about the service that created this bug can be found at: https://fedoraproject.org/wiki/Upstream_release_monitoring

Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.
Comment 3 Upstream Release Monitoring 2016-01-11 07:14:07 EST
Failed to kick off scratch build.

list index out of range
Comment 4 Elliott Sales de Andrade 2016-02-18 19:32:52 EST
Ping? I don't have any hopes for mpl 2.x, but Rawhide is about to branch for Fedora 24 in a few days, so it'd be nice to have mpl 1.5.1 at least.
Comment 5 Thomas Spura 2016-02-19 01:08:59 EST
Last time, I tried to update, were sins hiccups such as bundled code and failing test suite (I can't remember off hand the exact reasons for not updating matplotlib)...

Co-maintainers are welcome...
Comment 6 Elliott Sales de Andrade 2016-02-21 21:39:06 EST
Unfortunately, I can't help with maintainership since I'm not a packagers.

But I did look into it and it looks like the trouble is with Agg, which is now a checkout from svn. I've opened Bug 1310465 in the hopes that all Fedora's patches can be consolidated upstream and then when that package gets updated, matplotlib won't have any trouble using it.
Comment 7 Gwyn Ciesla 2016-03-02 10:10:12 EST
Hi, agg maintainer, I think using bundled agg is the best option, and when you've done that I'll retire agg.
Comment 8 Thomas Spura 2016-04-04 09:53:19 EDT
(In reply to Elliott Sales de Andrade from comment #6)
> Unfortunately, I can't help with maintainership since I'm not a packagers.
> 
> But I did look into it and it looks like the trouble is with Agg, which is
> now a checkout from svn. I've opened Bug 1310465 in the hopes that all
> Fedora's patches can be consolidated upstream and then when that package
> gets updated, matplotlib won't have any trouble using it.

If you are interested in becoming a packager, I can help you with that :)
For more information see, e.g.:
- https://fedoraproject.org/wiki/How_to_get_sponsored_into_the_packager_group
- https://fedoraproject.org/wiki/Join_the_package_collection_maintainers

(In reply to Jon Ciesla from comment #7)
> Hi, agg maintainer, I think using bundled agg is the best option, and when
> you've done that I'll retire agg.

It seems building the html fails right now... :/
From http://koji.fedoraproject.org/koji/taskinfo?taskID=13553891:
+ /usr/bin/python2 make.py html
Running Sphinx v1.3.1
Configuration error:
The configuration file (or one of the modules it imports) called sys.exit()
Building HTML failed.
Comment 9 Gwyn Ciesla 2016-04-05 11:16:03 EDT
I think I've got it worked out.  If so I'll get a build out, and if successful, retire agg.
Comment 10 Upstream Release Monitoring 2016-04-05 14:18:03 EDT
limb's python-matplotlib-1.5.1-2.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=751328
Comment 11 Gwyn Ciesla 2016-04-05 14:20:58 EDT
Just needed to BuildRequires: python[2,3]-cycler.
Comment 12 Thomas Spura 2016-04-06 17:23:13 EDT
Thanks, Jon.
Comment 13 Fedora Update System 2016-04-06 17:25:51 EDT
python-matplotlib-1.5.1-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6b8bc6225f
Comment 14 Fedora Update System 2016-04-07 12:53:26 EDT
python-matplotlib-1.5.1-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6b8bc6225f
Comment 15 Joachim Frieben 2016-04-07 15:10:29 EDT
It seems that Python module "cycler" is required by release 1.5.1, e.g. try sample script pcolormesh_levels.py. Please add python2-cycler and python3-cycler, respectively, as required packages to the spec file.
Comment 16 Fedora Update System 2016-04-07 18:31:29 EDT
python-matplotlib-1.5.1-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-6b8bc6225f
Comment 17 Fedora Update System 2016-04-08 12:53:21 EDT
python-matplotlib-1.5.1-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-6b8bc6225f
Comment 18 Upstream Release Monitoring 2016-04-30 15:04:11 EDT
corsepiu's python-matplotlib-1.5.1-4.fc25 completed http://koji.fedoraproject.org/koji/buildinfo?buildID=758990
Comment 19 Fedora Update System 2016-05-07 08:11:23 EDT
python-matplotlib-1.5.1-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.