Bug 1276833 - [abrt] gnome-shell: load_pixbuf_thread(): gnome-shell killed by SIGABRT
Summary: [abrt] gnome-shell: load_pixbuf_thread(): gnome-shell killed by SIGABRT
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:f37dee9f04478b5cb259604e115...
: 1276876 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-31 06:57 UTC by Adam Williamson
Modified: 2015-11-01 20:38 UTC (History)
7 users (show)

Fixed In Version: gnome-shell-3.19.1-2.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-01 00:10:34 UTC


Attachments (Terms of Use)
File: backtrace (54.51 KB, text/plain)
2015-10-31 06:57 UTC, Adam Williamson
no flags Details
File: cgroup (199 bytes, text/plain)
2015-10-31 06:57 UTC, Adam Williamson
no flags Details
File: core_backtrace (26.44 KB, text/plain)
2015-10-31 06:57 UTC, Adam Williamson
no flags Details
File: dso_list (24.00 KB, text/plain)
2015-10-31 06:57 UTC, Adam Williamson
no flags Details
File: environ (1.08 KB, text/plain)
2015-10-31 06:57 UTC, Adam Williamson
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-31 06:57 UTC, Adam Williamson
no flags Details
File: maps (120.37 KB, text/plain)
2015-10-31 06:57 UTC, Adam Williamson
no flags Details
File: mountinfo (4.01 KB, text/plain)
2015-10-31 06:57 UTC, Adam Williamson
no flags Details
File: open_fds (5.46 KB, text/plain)
2015-10-31 06:57 UTC, Adam Williamson
no flags Details
File: proc_pid_status (1.14 KB, text/plain)
2015-10-31 06:57 UTC, Adam Williamson
no flags Details
File: var_log_messages (28 bytes, text/plain)
2015-10-31 06:57 UTC, Adam Williamson
no flags Details

Description Adam Williamson 2015-10-31 06:57:18 UTC
Description of problem:
Upgraded from F23 to Rawhide, dnf made a mess, fixed it, this showed up on first boot.

Version-Release number of selected component:
gnome-shell-3.19.1-1.fc24

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        gnome-shell --mode=gdm --wayland --display-server
crash_function: load_pixbuf_thread
executable:     /usr/bin/gnome-shell
global_pid:     2106
kernel:         4.3.0-0.rc7.git2.1.fc24.x86_64
runlevel:       N 5
type:           CCpp
uid:            42

Truncated backtrace:
Thread no. 1 (3 frames)
 #4 load_pixbuf_thread at st/st-texture-cache.c:442
 #5 g_task_thread_pool_thread at gtask.c:1287
 #7 g_thread_proxy at gthread.c:778

Comment 1 Adam Williamson 2015-10-31 06:57:22 UTC
Created attachment 1088126 [details]
File: backtrace

Comment 2 Adam Williamson 2015-10-31 06:57:23 UTC
Created attachment 1088127 [details]
File: cgroup

Comment 3 Adam Williamson 2015-10-31 06:57:24 UTC
Created attachment 1088128 [details]
File: core_backtrace

Comment 4 Adam Williamson 2015-10-31 06:57:25 UTC
Created attachment 1088129 [details]
File: dso_list

Comment 5 Adam Williamson 2015-10-31 06:57:27 UTC
Created attachment 1088130 [details]
File: environ

Comment 6 Adam Williamson 2015-10-31 06:57:28 UTC
Created attachment 1088131 [details]
File: limits

Comment 7 Adam Williamson 2015-10-31 06:57:29 UTC
Created attachment 1088132 [details]
File: maps

Comment 8 Adam Williamson 2015-10-31 06:57:30 UTC
Created attachment 1088133 [details]
File: mountinfo

Comment 9 Adam Williamson 2015-10-31 06:57:31 UTC
Created attachment 1088134 [details]
File: open_fds

Comment 10 Adam Williamson 2015-10-31 06:57:32 UTC
Created attachment 1088135 [details]
File: proc_pid_status

Comment 11 Adam Williamson 2015-10-31 06:57:34 UTC
Created attachment 1088136 [details]
File: var_log_messages

Comment 12 Adam Williamson 2015-10-31 15:55:02 UTC
Note: this happens when running GDM, it looks like. If I boot to runlevel 3 and 'startx', that works OK.

Comment 13 Joachim Frieben 2015-10-31 16:48:09 UTC
Booting to runlevel 3 and executing 'gnome-session --session=gnome' fails but executing 'gnome-session --session=gnome-wayland' succeeds.

Comment 14 Adam Williamson 2015-10-31 17:30:27 UTC
startx gave me a working GNOME (on X) session...

Comment 15 Pavlo Rudyi 2015-10-31 18:02:49 UTC
Another user experienced a similar problem:

Latest upgrade to gdm-3.19.1 is broken.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        gnome-shell --mode=gdm --wayland --display-server
crash_function: load_pixbuf_thread
executable:     /usr/bin/gnome-shell
global_pid:     1283
kernel:         4.3.0-0.rc7.git2.2.fc24.x86_64
package:        gnome-shell-3.19.1-1.fc24
reason:         gnome-shell killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            42

Comment 16 Adam Williamson 2015-10-31 18:10:51 UTC
Oh, BTW, I did try with Wayland disabled in custom.conf, didn't seem to help.

Comment 17 Joachim Frieben 2015-10-31 18:32:32 UTC
(In reply to Pavlo Rudyi from comment #15)
There is no gdm-3.19.1 in rawhide yet, current version is gdm-3.18.0; you probably mean gnome-shell-3.19.1.

Comment 18 Pavlo Rudyi 2015-10-31 18:34:32 UTC
(In reply to Joachim Frieben from comment #17)
> (In reply to Pavlo Rudyi from comment #15)
> There is no gdm-3.19.1 in rawhide yet, current version is gdm-3.18.0; you
> probably mean gnome-shell-3.19.1.

Yes, sorry.

Comment 19 Kalev Lember 2015-10-31 23:56:27 UTC
I put a patch that should fix this to https://bugzilla.gnome.org/show_bug.cgi?id=757418

Comment 20 Joachim Frieben 2015-11-01 07:26:23 UTC
(In reply to awilliam from comment #14)
Booting to runlevel 3 and startx does give a working GNOME/X session but:

  $gnome-session --session=gnome
  Terminated

whereas

  $gnome-session --session=gnome-wayland

fires up a working GNOME/Xwayland session.

Comment 21 Kalev Lember 2015-11-01 20:38:44 UTC
*** Bug 1276876 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.