Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1276876 - gdm fails after upgrade to gnome-shell 3.19.1-1.fc24
Summary: gdm fails after upgrade to gnome-shell 3.19.1-1.fc24
Keywords:
Status: CLOSED DUPLICATE of bug 1276833
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-31 19:26 UTC by Carlo Mandelli
Modified: 2015-11-01 20:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-01 20:38:44 UTC
Type: Bug


Attachments (Terms of Use)

Description Carlo Mandelli 2015-10-31 19:26:42 UTC
Description of problem:
Upgrading from f22 to rawhide ends with "Oh no! Something has gone wrong" screen after first reboot. 

Oct 31 19:55:26 rawhide gnome-session[1732]: ** (gnome-shell:1802): CRITICAL **: atk_object_get_role: assertion 'ATK_IS
Oct 31 19:55:26 rawhide gnome-session[1732]: ** (gnome-shell:1802): CRITICAL **: atk_object_get_role: assertion 'ATK_IS
Oct 31 19:55:26 rawhide dbus[719]: [system] Activating service name='org.freedesktop.realmd' (using servicehelper)
Oct 31 19:55:26 rawhide audit[1812]: ANOM_ABEND auid=4294967295 uid=42 gid=42 ses=4294967295 subj=system_u:system_r:xdm
Oct 31 19:55:26 rawhide gnome-session[1732]: **
Oct 31 19:55:26 rawhide gnome-session[1732]: St:ERROR:st/st-texture-cache.c:442:load_pixbuf_thread: assertion failed: (
Oct 31 19:55:26 rawhide realmd[1834]: Loaded settings from: /usr/lib/realmd/realmd-defaults.conf /usr/lib/realmd/realmd
Oct 31 19:55:26 rawhide realmd[1834]: holding daemon: startup
Oct 31 19:55:26 rawhide realmd[1834]: starting service
Oct 31 19:55:26 rawhide abrt-hook-ccpp[1835]: Not saving repeating crash in '/usr/bin/gnome-shell'
Oct 31 19:55:26 rawhide realmd[1834]: connected to bus
Oct 31 19:55:26 rawhide realmd[1834]: released daemon: startup
Oct 31 19:55:26 rawhide dbus[719]: [system] Successfully activated service 'org.freedesktop.realmd'
Oct 31 19:55:26 rawhide realmd[1834]: claimed name on bus: org.freedesktop.realmd
Oct 31 19:55:26 rawhide gnome-session-binary[1732]: WARNING: App 'gnome-shell.desktop' respawning too quickly
Oct 31 19:55:26 rawhide gnome-session[1732]: gnome-session-binary[1732]: WARNING: App 'gnome-shell.desktop' respawning 
Oct 31 19:55:26 rawhide gnome-session-binary[1732]: Unrecoverable failure in required component gnome-shell.desktop

Version-Release number of selected component (if applicable):
gnome-shell 3.19.1-1.fc24

How reproducible:
install fc22 and upgrade to rawhide

Steps to Reproduce:
1. install fc22
2. upgrade to rawhide with dnf
3. reboot

Actual results:
"Oh no! Something has gone wrong" screen

Expected results:
gdm login screen

Additional info:
Downgrade to gnome-shell-3.18.1-1.fc23 solved to issue.

Comment 1 Kalev Lember 2015-11-01 20:38:44 UTC

*** This bug has been marked as a duplicate of bug 1276833 ***


Note You need to log in before you can comment on or make changes to this bug.