Bug 1276955 - vdagent hangs in win7 with 100% cpu
vdagent hangs in win7 with 100% cpu
Status: CLOSED DUPLICATE of bug 1275789
Product: Fedora
Classification: Fedora
Component: spice-vdagent (Show other bugs)
22
x86_64 Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Christophe Fergeau
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-01 13:08 EST by cvandesande
Modified: 2015-11-01 17:04 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-01 17:04:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cvandesande 2015-11-01 13:08:18 EST
Description of problem:
The vdagent service from spice-guest-tools-100 hangs with 100% cpu usage on the guest os.

Version-Release number of selected component (if applicable):
spice-guest-tools-0.100.exe

How reproducible:
Everytime

Steps to Reproduce:
1. Fresh install guest OS Windows 7 64bit
2. Make sure  Spice agent (spicevmc) is present in virt-manager/virsh xml
3. Install spice-guest-tools-0.100.exe in guest
4. vdagent hangs, even on reboot

Actual results:
copy/paste doesn't work, auto-resize screen not available through virt-manger

Expected results:
vdagent ideal, copy/paste between host and guest working

Additional info:
Vdagent logs
3456::INFO::2015-11-01 18:02:23,143::log_version::0.5.1.0
3456::INFO::2015-11-01 18:02:23,143::DesktopLayout::consistent_displays::#qxls 1 #others 0
3456::INFO::2015-11-01 18:02:23,143::VDAgent::init_vio_serial::Failed opening \\.\Global\com.redhat.spice.0, error 2
3596::INFO::2015-11-01 18:02:26,158::VDAgent::run::***Agent started in session 1***
3596::INFO::2015-11-01 18:02:26,158::log_version::0.5.1.0
3596::INFO::2015-11-01 18:02:26,158::DesktopLayout::consistent_displays::#qxls 1 #others 0
3596::INFO::2015-11-01 18:02:26,158::VDAgent::init_vio_serial::Failed opening \\.\Global\com.redhat.spice.0, error 2

vdservice logs:
1724::INFO::2015-11-01 18:02:10,045::VDService::control_handler::Session 1 LOGON
1744::INFO::2015-11-01 18:02:11,131::VDService::execute::Agent killed
1744::INFO::2015-11-01 18:02:14,143::VDService::execute::Agent killed
1744::INFO::2015-11-01 18:02:17,143::VDService::execute::Agent killed
1744::INFO::2015-11-01 18:02:20,143::VDService::execute::Agent killed
1744::INFO::2015-11-01 18:02:23,143::VDService::execute::Agent killed
1744::INFO::2015-11-01 18:02:26,158::VDService::execute::Agent killed
1744::INFO::2015-11-01 18:02:29,158::VDService::execute::Agent killed
1744::INFO::2015-11-01 18:02:32,158::VDService::execute::Agent killed
1744::INFO::2015-11-01 18:02:35,158::VDService::execute::Agent killed
1744::INFO::2015-11-01 18:02:38,158::VDService::execute::Agent killed
1744::INFO::2015-11-01 18:02:41,158::VDService::restart_agent::Agent restarted too many times
1744::INFO::2015-11-01 18:02:41,158::VDService::stop::Service stopped
1744::INFO::2015-11-01 18:02:41,158::VDService::main::***Service stopped***
Comment 1 Cole Robinson 2015-11-01 17:04:54 EST

*** This bug has been marked as a duplicate of bug 1275789 ***

Note You need to log in before you can comment on or make changes to this bug.