This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1275789 - qemu-2.3.1-7.fc22 breaks spice agent resize, copy+paste, etc.
qemu-2.3.1-7.fc22 breaks spice agent resize, copy+paste, etc.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
: 1275408 1275499 1275832 1276955 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-27 14:18 EDT by Cole Robinson
Modified: 2015-11-24 19:36 EST (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-24 19:36:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cole Robinson 2015-10-27 14:18:15 EDT
qemu-2.3.1-7.fc22 seems to break interaction with the guest spice-vdagent. There's even reports of this hanging windows VMs

The issue is that the package was built against spice-server 0.12.6, but if it runs against an older spice-server, everything misbehaves. More info over here: https://bugzilla.redhat.com/show_bug.cgi?id=1271153#c30
Comment 1 Cole Robinson 2015-10-27 14:18:45 EDT
*** Bug 1275499 has been marked as a duplicate of this bug. ***
Comment 2 Cole Robinson 2015-10-27 14:19:18 EDT
*** Bug 1275408 has been marked as a duplicate of this bug. ***
Comment 3 Cole Robinson 2015-10-27 14:21:58 EDT
Pushing spice 0.12.6 to stable will more or less fix this, but anyone hitting issues in the interim can do:

sudo yum --enablerepo=updates-testing update spice\*
Comment 4 Cole Robinson 2015-10-28 08:59:42 EDT
*** Bug 1275832 has been marked as a duplicate of this bug. ***
Comment 5 Daniel 2015-10-28 22:11:25 EDT
Thank you very much for the solution.
I installed spice 0.12.6 packages and this solved my problem.
Comment 6 Raphael Groner 2015-10-30 17:00:40 EDT
spice-server-0.12.5-6.fc22.x86_64 → b0rken
spice-server-0.12.6-1.fc22.x86_64 → works
Comment 7 Cole Robinson 2015-11-01 17:04:54 EST
*** Bug 1276955 has been marked as a duplicate of this bug. ***
Comment 8 Cole Robinson 2015-11-24 19:36:38 EST
that spice version is in stable now

Note You need to log in before you can comment on or make changes to this bug.