Bug 1277000 - "dnf builddep" crashes with AttributeError
"dnf builddep" crashes with AttributeError
Status: CLOSED DUPLICATE of bug 1272936
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
23
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-01 22:40 EST by Kevin Lipe
Modified: 2015-11-01 23:55 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-01 23:55:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Lipe 2015-11-01 22:40:46 EST
Description of problem:

Fresh install of Fedora 23 beta, Cinnamon desktop. Can't run "dnf builddep" for any package. Always crashes with a Python error (pasted her)):

[kevin@localhost bin]$ sudo dnf builddep emacs
enabling fedora-source repository
enabling updates-source repository
Failed to synchronize cache for repo 'tuxor-tp_smapi' from 'https://copr-be.cloud.fedoraproject.org/results/tuxor/tp_smapi/fedora-23-x86_64/': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried, disabling.
Last metadata expiration check performed 0:06:39 ago on Sun Nov  1 22:30:52 2015.
Traceback (most recent call last):
  File "/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 198, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 84, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 136, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1091, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 76, in inner
    return func(*args, **kwds)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 142, in run
    self._remote_deps(pkgspec)
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 213, in _remote_deps
    package).get_best_query(self.base.sack)})
  File "/usr/lib/python3.4/site-packages/dnf-plugins/builddep.py", line 212, in <setcomp>
    for pkg in dnf.subject.Subject(
  File "/usr/lib/python3.4/site-packages/dnfpluginscore/lib.py", line 170, in package_source_name
    srcname = package.sourcerpm.rstrip(".src.rpm")
AttributeError: 'NoneType' object has no attribute 'rstrip'

Version-Release number of selected component (if applicable):

[kevin@localhost bin]$ dnf --version
1.1.3
  Installed: dnf-0:1.1.3-1.fc23.noarch at 2015-11-02 03:09
  Built    : Fedora Project at 2015-10-14 16:54

  Installed: rpm-0:4.13.0-0.rc1.4.fc23.x86_64 at 2015-11-02 03:07
  Built    : Fedora Project at 2015-10-12 13:48


How reproducible:

Happens every time I run "dnf builddep" on a fresh installation of Fedora 23 beta

Steps to Reproduce:
1. run "sudo dnf builddep (package name)"
2. ...
3. crash :(

Actual results:

Crash of dnf

Expected results:[kevin@localhost bin]$ dnf --version
1.1.3
  Installed: dnf-0:1.1.3-1.fc23.noarch at 2015-11-02 03:09
  Built    : Fedora Project at 2015-10-14 16:54

  Installed: rpm-0:4.13.0-0.rc1.4.fc23.x86_64 at 2015-11-02 03:07
  Built    : Fedora Project at 2015-10-12 13:48


Installation of packages needed to build whichever package I'm specifying (emacs checked out from git, in this case)

Additional info: This happens on a fresh install on my thinkpad, and also happens in a VM I set up to see if something was wrong with my particular installation.
Comment 1 Kevin Lipe 2015-11-01 23:55:42 EST

*** This bug has been marked as a duplicate of bug 1272936 ***

Note You need to log in before you can comment on or make changes to this bug.