Bug 1277076 - Monitor should restart the worker process when Changelog agent dies
Monitor should restart the worker process when Changelog agent dies
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Aravinda VK
:
Depends On:
Blocks: 1279362
  Show dependency treegraph
 
Reported: 2015-11-02 04:33 EST by Aravinda VK
Modified: 2016-06-16 09:42 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1279362 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:42:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2015-11-02 04:33:31 EST
Description of problem:

Geo-replication will not detect if Changelog agent dies. Status shows all good but without any progress since Changelog Agent is not available.


Version-Release number of selected component (if applicable):
Mainline and 3.7.x

How reproducible:
Always


Steps to Reproduce:
1. Start Geo-replication and Wait till Status becomes "Active"
2. Kill Agent process and check the Geo-replication status(ps aux | grep gsyncd | grep agent)


Actual results:
Status shows "Active" even though status is "Faulty"

Expected results:
Status should show "Faulty" and Monitor should respawn the worker
Comment 1 Vijay Bellur 2015-11-02 04:34:34 EST
REVIEW: http://review.gluster.org/12485 (geo-rep: Kill Geo-rep Worker when Agent process dies) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 2 Vijay Bellur 2015-11-02 06:49:57 EST
REVIEW: http://review.gluster.org/12485 (geo-rep: Kill Geo-rep Worker when Agent process dies) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 3 Niels de Vos 2016-06-16 09:42:46 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.