Bug 1279362 - Monitor should restart the worker process when Changelog agent dies
Monitor should restart the worker process when Changelog agent dies
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
3.7.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Aravinda VK
:
Depends On: 1277076
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-09 04:53 EST by Aravinda VK
Modified: 2016-04-19 03:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1277076
Environment:
Last Closed: 2016-02-15 01:26:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aravinda VK 2015-11-09 04:53:33 EST
+++ This bug was initially created as a clone of Bug #1277076 +++

Description of problem:

Geo-replication will not detect if Changelog agent dies. Status shows all good but without any progress since Changelog Agent is not available.


Version-Release number of selected component (if applicable):
Mainline and 3.7.x

How reproducible:
Always


Steps to Reproduce:
1. Start Geo-replication and Wait till Status becomes "Active"
2. Kill Agent process and check the Geo-replication status(ps aux | grep gsyncd | grep agent)


Actual results:
Status shows "Active" even though status is "Faulty"

Expected results:
Status should show "Faulty" and Monitor should respawn the worker

--- Additional comment from Vijay Bellur on 2015-11-02 04:34:34 EST ---

REVIEW: http://review.gluster.org/12485 (geo-rep: Kill Geo-rep Worker when Agent process dies) posted (#1) for review on master by Aravinda VK (avishwan@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-02 06:49:57 EST ---

REVIEW: http://review.gluster.org/12485 (geo-rep: Kill Geo-rep Worker when Agent process dies) posted (#2) for review on master by Aravinda VK (avishwan@redhat.com)
Comment 1 Aravinda VK 2015-11-09 04:55:16 EST
Patch sent Upstream for review
http://review.gluster.org/#/c/12550/
Comment 2 Vijay Bellur 2015-11-25 02:17:08 EST
COMMIT: http://review.gluster.org/12550 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit a694e86cd5340fff1143e2ac55ec908d3ef890b3
Author: Aravinda VK <avishwan@redhat.com>
Date:   Fri Oct 30 17:06:58 2015 +0530

    geo-rep: Kill Geo-rep Worker when Agent process dies
    
    When Changelog agent process dies, Geo-replication fails to detect
    and worker will run without respective Changelog agent. Status shows
    Active/Passive without any progress.
    
    With this patch, Worker process gets killed whenever Changelog
    agent dies.
    
    Change-Id: I30b4cc77f924f7e8174b8bfe415ac17f0b3851b4
    Signed-off-by: Aravinda VK <avishwan@redhat.com>
    BUG: 1279362
    Reviewed-on: http://review.gluster.org/12485
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    (cherry picked from commit 5d1ff7efd6ab3bd29a29922a9ea1e1aaf02544ad)
    Reviewed-on: http://review.gluster.org/12550
Comment 3 Kaushal 2016-04-19 03:47:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.