Bug 1277126 - [New] - Files in a tiered volume gets promoted when bitd signs them
[New] - Files in a tiered volume gets promoted when bitd signs them
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.1.2
Assigned To: Bug Updates Notification Mailing List
RamaKasturi
: ZStream
Depends On: 1278326
Blocks: 1260783 1260923
  Show dependency treegraph
 
Reported: 2015-11-02 07:32 EST by RamaKasturi
Modified: 2016-09-17 11:41 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1278326 (view as bug list)
Environment:
Last Closed: 2016-03-01 00:50:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RamaKasturi 2015-11-02 07:32:10 EST
Description of problem:
Have an EC volume as cold tier and attached replicate volume as hot tier and enabled bitrot on the volume. Once files are not accessed they get demoted and bitd tries to sign the files. Once the files are signed it gets promoted to hot tier. If the attrs of a file changes,  tiering should not promote the file.

Version-Release number of selected component (if applicable):
glusterfs-3.7.5-5.el6rhs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have a EC distribute disperse as cold tier and replicate volume as hot tier.
2. Mount the volume using fuse mount and create some files in the volume
3. Once the files get demoted to cold tier, bitd waits for 120sec to sign  the file.

Actual results:
Once the file is signed, file gets promoted to hot tier.

Expected results:
File should not get promoted as there is no change in the contents of the file.

Additional info:
Comment 2 RamaKasturi 2015-11-02 07:39:13 EST
sos reports can be found at the link below:

http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/1277126/
Comment 3 RamaKasturi 2015-11-05 01:30:12 EST
Files should not get heated up for any of the internal ops going on the volume
Comment 4 RamaKasturi 2015-11-05 01:46:32 EST
Cannot test scrubber because, signature is heating up the files and when a file is corrupted from the backend, tiering will promote the file and signature is calculated again. So by the time scrubber comes and checks the file signature it will match with the signature and what scrubber calculated, so file will never be marked as bad.
Comment 6 Dan Lambright 2015-11-08 10:49:27 EST
Patch 60999 adds bitrot fops to the "internal" list, fops on that list are ignored for heat calculations.
Comment 7 RamaKasturi 2015-11-19 08:17:49 EST
Verified and works fine with build glusterfs-3.7.5-6.el7rhgs.x86_64.

When bitd signs the files , files does not get promoted to hot tier.
Comment 9 errata-xmlrpc 2016-03-01 00:50:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.