Bug 1278326 - [New] - Files in a tiered volume gets promoted when bitd signs them
[New] - Files in a tiered volume gets promoted when bitd signs them
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Dan Lambright
bugs@gluster.org
: Triaged
Depends On:
Blocks: 1277126 1278640
  Show dependency treegraph
 
Reported: 2015-11-05 04:32 EST by Joseph Elwin Fernandes
Modified: 2016-06-16 09:43 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1277126
: 1278640 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:43:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-10 20:46:13 EST
COMMIT: http://review.gluster.org/12555 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit d025d954a5c593ccb0838788e165c36cb3537b25
Author: Joseph Fernandes <josferna@redhat.com>
Date:   Mon Nov 9 20:36:11 2015 +0530

    tier/ctr: ignoring bitrot scrubber fops
    
    We had missed adding  GF_CLIENT_PID_SCRUB to the internal fops
    list of bitrot. Doing that in this fix
    
    Change-Id: I0c7de37e2bf625fb577a32a599a885ee95f5d3bd
    BUG: 1278326
    Signed-off-by: Joseph Fernandes <josferna@redhat.com>
    Reviewed-on: http://review.gluster.org/12555
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 2 Niels de Vos 2016-06-16 09:43:12 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.