Bug 1277162 - Wrong dependency version number for pillow.
Wrong dependency version number for pillow.
Status: CLOSED DUPLICATE of bug 1267446
Product: Fedora
Classification: Fedora
Component: python-reportlab (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 09:29 EST by Matthieu Gautier
Modified: 2015-11-30 02:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-30 02:18:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthieu Gautier 2015-11-02 09:29:15 EST
Description of problem:
Repotlab has a wrong version number for the pillow dependency.

setup.py contains :

    install_requires=['pillow ==2.0.0, >=2.4.0','pip>=1.4.1', 'setuptools>=2.2']

Pillow cannot be ==2.0.0 and >=2.4.0 in the same time.

Version-Release number of selected component (if applicable):
Reportlab 3.1.8

How reproducible:
All the time.

Steps to Reproduce:
1. Install python-reportlab on fedora23
2.
3.

Actual results:
Cannot run any python module using reportlab. For example :

$ rst2pdf
Traceback (most recent call last):
  File "/usr/bin/rst2pdf", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3084, in <module>
    @_call_aside
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3070, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3097, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 653, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 666, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pillow==2.0.0,>=2.4.0' distribution was not found and is required by reportlab



Expected results:
Pillow dependency should be >=2.4.0

Additional info:
This bug is fix in the 3.2.0 upstream version.
Comment 1 Satoru SATOH 2015-11-29 21:45:15 EST
I also run into this issue and cannot use rst2pdf w/o some tweaks.

And I found that 3.2.0 version was built for F24 already [1] and 
confirmed that I can rebuild it for F23 also with mock (mockbuild)
and that rebuilt one works w/o any apparent issues as far as I tested.

Could you please build the newer version for F23 (current stable) also?


[1] http://koji.fedoraproject.org/koji/buildinfo?buildID=698069
Comment 2 Peter Gordon 2015-11-30 02:18:57 EST
Hello, Satoru. 

I took over as maintainer for python-reportlab after it reported as in danger of being orphaned in a Rawhide report about a month ago. However, for some reason I've only been granted commit access in the Rawhide branch; and my commit requests for the Fedora 22 and Fedora 23 branches are still pending in PkgDB. I'll try to bump those requests to the admins, and update the package in those branches as soon as I'm on the ACLs to do so.

Thanks.

*** This bug has been marked as a duplicate of bug 1267446 ***

Note You need to log in before you can comment on or make changes to this bug.