Bug 1267446 - Missing Requires: on pillow
Missing Requires: on pillow
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-reportlab (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: William Moreno
Fedora Extras Quality Assurance
:
: 1277162 1303121 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 01:02 EDT by Ben Boeckel
Modified: 2016-05-07 08:10 EDT (History)
10 users (show)

See Also:
Fixed In Version: python-reportlab-3.3.0-1.fc23 python-reportlab-3.3.0-1.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-24 01:21:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Boeckel 2015-09-30 01:02:57 EDT
Traceback (most recent call last):
  File "/usr/bin/rst2pdf", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3084, in <module>
    @_call_aside
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3070, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3097, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 653, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 666, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pillow==2.0.0,>=2.4.0' distribution was not found and is required by reportlab
Comment 1 Ben Boeckel 2015-09-30 01:04:00 EDT
Hrm. I do have python-pillow installed:

python-pillow-2.9.0-2.fc24.x86_64
Comment 2 Fedora Admin XMLRPC Client 2015-10-25 05:18:50 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Fedora Admin XMLRPC Client 2015-10-26 04:56:15 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 4 Peter Gordon 2015-10-28 12:04:34 EDT
This looks more likely to be a problem with RST2PDF; reassigning there.

Unfortunately, I'm not able to reproduce this -- if I simply run 'rst2pdf' with no parameters, it outputs an empty PDF source. Also, rst2pdf has a direct dependency on python-reportlab which in turn requires python-pillow; so at a glance it appears that this should always be satisfied...
Comment 5 Sascha Zantis 2015-11-07 11:34:10 EST
I installed it today, and it doesn't work. Simply runnng 'rst2pdf' creates the following output:

Traceback (most recent call last):
  File "/usr/bin/rst2pdf", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3084, in <module>
    @_call_aside
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3070, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3097, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 653, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 666, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 839, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pillow==2.0.0,>=2.4.0' distribution was not found and is required by reportlab


python-pillow and python3-pillow are installed.

Fedora 23 here.

Regards, 
Sascha
Comment 6 Masatake YAMATO 2015-11-08 15:16:55 EST
I don't know well about python. However, following patch allows me to run rst2pdf.


--- usr/lib64/python2.7/site-packages/reportlab-3.1.8-py2.7.egg-info/requires.txt	2015-06-19 05:44:23.000000000 +0900
+++ /usr/lib64/python2.7/site-packages/reportlab-3.1.8-py2.7.egg-info/requires.txt	2015-11-09 05:02:43.253475135 +0900
@@ -1,3 +1,3 @@
-pillow ==2.0.0, >=2.4.0
+pillow>=2.4.0
 pip>=1.4.1
 setuptools>=2.2

...
I inspected the upstream hg repository and I found the same fix.

https://bitbucket.org/rptlab/reportlab/commits/4df3c1696c1beee18f8233ce1dfe39f1f7c03391
Comment 7 Peter Gordon 2015-11-08 23:51:51 EST
Oh, I see. It cannot possibly have a version both equal to 2.0.0 and "at least 2.4.0" simultaneously. Good catch, I'll add that fix into Fedora's package after I finish this Topology homework. :)

Thanks and regards.
Comment 8 Peter Gordon 2015-11-30 02:18:57 EST
*** Bug 1277162 has been marked as a duplicate of this bug. ***
Comment 9 Lenz Grimmer 2016-01-05 12:35:48 EST
Any news on this one? I just stumbled over this bug myself and fixed it manually by applying the diff referenced in comment#6 above, but it would be nice to have it fixed in the upstream Fedora RPM as well :)

Could you please either apply this patch on top of the 3.1.8 RPM, or update python-reportlab to version 3.2.0 for FC32 as well?
Comment 10 Kevin Cousin 2016-01-26 12:48:42 EST
I add this bug too. Workaround on comment#6 works well for me.
Comment 11 Jan Kurik 2016-02-24 08:48:16 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 12 Fedora Admin XMLRPC Client 2016-02-27 15:58:12 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 13 Fedora Update System 2016-04-11 11:13:42 EDT
python-reportlab-3.3.0-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-62bb566860
Comment 14 Fedora Update System 2016-04-11 11:14:16 EDT
python-reportlab-3.3.0-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-e8237eeb5d
Comment 15 Fedora Update System 2016-04-12 06:52:52 EDT
python-reportlab-3.3.0-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-e8237eeb5d
Comment 16 Fedora Update System 2016-04-13 05:27:22 EDT
python-reportlab-3.3.0-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-62bb566860
Comment 17 Dridi Boukelmoune 2016-04-17 17:09:38 EDT
*** Bug 1303121 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2016-04-24 01:21:07 EDT
python-reportlab-3.3.0-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 19 Fedora Update System 2016-05-07 08:10:37 EDT
python-reportlab-3.3.0-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.