Bug 1277326 - gnome-shell unusable over xrdp/vnc session
gnome-shell unusable over xrdp/vnc session
Status: CLOSED DUPLICATE of bug 1279146
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
23
i686 Linux
unspecified Severity high
: ---
: ---
Assigned To: Jan Grulich
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-02 22:42 EST by Bojan Smojver
Modified: 2015-11-19 22:23 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 22:23:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bojan Smojver 2015-11-02 22:42:50 EST
Description of problem:
Upgraded an F-22 i686 VM to F-23 using dnf. I can see the desktop and start the apps, but redrawing has all gone nuts. Artefacts of previous windows, even the overview mode (i.e. dash etc.) are appearing as the mouse is moved around. Eventually, the text editing cursor appears and the session locks up. 

Version-Release number of selected component (if applicable):
gnome-shell-3.18.1-1

How reproducible:
Always.

Steps to Reproduce:
1. Start an xrdp/vnc session with vnc backend.
2. Run Gnome.
3. Pain. :-(

Actual results:
Redrawing madness.

Expected results:
Works fine in F-22.

Additional info:
Downgrading to F-22 now.
Comment 1 Bojan Smojver 2015-11-02 23:38:49 EST
As expected, downgrading the VM to F-22 makes everything sane again.
Comment 2 Bojan Smojver 2015-11-05 19:06:38 EST
Running 16-bit colour depth, to reduce bandwidth requirements, if it matters.
Comment 3 Sylvain Pasche 2015-11-19 11:25:24 EST
Might be a duplicate of bug 1279146
Comment 4 Sylvain Pasche 2015-11-19 11:27:23 EST
... or not. Are you using tigervnc?
Comment 5 Bojan Smojver 2015-11-19 15:28:38 EST
(In reply to Sylvain Pasche from comment #4)
> ... or not. Are you using tigervnc?

xrdp uses tigervnc in the back end. So, yeah, could be a duplicate.
Comment 6 Bojan Smojver 2015-11-19 22:23:08 EST
Yeah, build -4 is the fix for this one (rendering for sure, not quite sure on crashing yet - too early to tell).

*** This bug has been marked as a duplicate of bug 1279146 ***

Note You need to log in before you can comment on or make changes to this bug.