Bug 1279146 - Refresh Issues leads VNC to be unusable
Refresh Issues leads VNC to be unusable
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Grulich
Fedora Extras Quality Assurance
:
: 1277326 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-08 01:28 EST by Mike Kwong
Modified: 2016-01-20 13:13 EST (History)
10 users (show)

See Also:
Fixed In Version: tigervnc-1.5.0-4.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-22 19:22:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Kwong 2015-11-08 01:28:47 EST
Description of problem:
After upgrading to Fedora 23, I'm experiencing severe refresh issues, such that VNC is no longer usable. After rendering the screen, large parts of the screen would seemingly turn blank or flash back to a previous state / program rendering, and the viewer would seem out of sync with what is actually going on.

Version-Release number of selected component (if applicable):
gtk-vnc2.x86_64                          0.5.4-2.fc23              @@commandline
gvnc.x86_64                              0.5.4-2.fc23              @@commandline
libvncserver.x86_64                      0.9.10-0.7.20140718git9453be42.fc23
tigervnc-license.noarch                  1.5.0-3.fc23              @@commandline
tigervnc-server.x86_64                   1.5.0-3.fc23              @@commandline
tigervnc-server-minimal.x86_64           1.5.0-3.fc23              @@commandline

How reproducible:
Happens consistently after Fedora 23 upgrade. (Was working fine before that.)

Steps to Reproduce:
1. Set up ssh tunneling
2. Connect using either RealVNC chrome extension, or TigerVNC client from MacOS X
3.

Actual results:
severe refresh issues, such that VNC is no longer usable. After rendering the screen, large parts of the screen would seemingly turn blank or flash back to a previous state / program rendering, and the viewer would seem out of sync with what is actually going on.

Expected results:
Viewer should show the expected screen accurately, with minimal delay

Additional info:
Comment 1 Chris Egolf 2015-11-10 21:14:40 EST
I'm experiencing the same thing using the vncviewer client included in tigervnc-1.5.0-3.fc23.x86_64.  The VNC server is tigervnc-server-1.5.0-3.fc23.x86_64 using the standard GNOME desktop.  If I revert to the twm session, the screen refresh problem goes away. 

All the systems involved are now Fedora 23 and did not have this issue prior to the upgrade.
Comment 2 Pete McDonnell 2015-11-19 09:04:40 EST
As noted in:

https://github.com/TigerVNC/tigervnc/issues/235#issuecomment-157980861

I believe this may be an issue in the compiled RPM.  When I downloaded the source RPM and rebuilt it using:

rpmbuild --rebuild tigervnc-1.5.0-3.fc23.src.rpm 

Then upgraded all built RPMs from rpmbuild/RPMS/x86_64/ (rpm -Uvh *)

the issue was resolved.

As noted by another poster in the linked thread, The following was found in the vnc server log before/after the install of the rebuilt version:

Binary RPM provided by Fedora 23 shows this message in the log:
Underlying X server release 11799901, The X.Org Foundation

Rebuilt RPM shows this message in the log:
Underlying X server release 11800000, The X.Org Foundation
Comment 3 Fedora Update System 2015-11-19 09:53:58 EST
tigervnc-1.5.0-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-4b843c0edd
Comment 4 Bojan Smojver 2015-11-19 22:23:08 EST
*** Bug 1277326 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2015-11-20 06:24:23 EST
tigervnc-1.5.0-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update tigervnc'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-4b843c0edd
Comment 6 Fedora Update System 2015-11-22 19:22:43 EST
tigervnc-1.5.0-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Martin Sebor 2016-01-20 13:13:22 EST
I still see this problem with tigervnc-server.1.6.0-1.fc23.

Note You need to log in before you can comment on or make changes to this bug.