Bug 1277406 - iphone applet not working with RHEL 6
iphone applet not working with RHEL 6
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gthumb (Show other bugs)
6.7
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Richard Hughes
Desktop QE
:
Depends On:
Blocks: 1269194
  Show dependency treegraph
 
Reported: 2015-11-03 04:25 EST by jigar
Modified: 2016-08-03 11:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-03 11:59:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jigar 2015-11-03 04:25:52 EST
Description of problem: Cannot use the iPhone applet with option "Open gThumb Image Viewer" AFTER "Allow" on iPhone.


Version-Release number of selected component (if applicable): gvfs-1.4.3-22

How reproducible: Frequently

Steps to Reproduce:

Open gThumb Image Viewer Option:

1. Connect iphone 5s 
2. Choose Open Folder instead -> you get in another applet the message "The media contains digital photos." and "Open gThumb Image Viewer".
3.Touch the "iPhone" folder sign at the left bottom of the applet and then select "Open gThumb Image Viewer".
4. Get a new applet "Import Photos" with display of a folder + name ("my_phone" in this case)

ERROR MESSAGE" An error occurred in the io-library ('Could not lock the device'): Camera is already in use.

6. lose the applets and restart the plug-in of my iPhone.


Open Folder Option:


1. Re-plug in iPhone, do "Allow" on iPhone, select "Open Folder"
2. get applet "iPhone" (as before) and select Open gThumb Image Viewer
3. choose File -> Open Location -> gphoto2://{usb:002,007]/
4. nothing happens

Open gThumb Photo Import Tool Option:

1. re-plug iPhone,  "Allow" on iPhone  select "Open gThumb Photo Import Tool"
2. this worked.

Actual results: Options "Open gThumb Image Viewer" & "Open Folder" do not work as expected.


Expected results: All the options should work as intended after connecting iphone


Additional info: This might be related https://bugzilla.redhat.com/show_bug.cgi?id=1165676
Comment 2 Ondrej Holy 2015-11-03 07:57:12 EST
As far as I know this isn't gvfs bug, but it is gthumb bug. There is several similar bug reports for Fedora. See Bug 552890.

Note You need to log in before you can comment on or make changes to this bug.