Bug 1277418 - (nette/security) Review Request: php-nette-security - Nette Security: Access Control Component
Review Request: php-nette-security - Nette Security: Access Control Component
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shawn Iwinski
Fedora Extras Quality Assurance
:
Depends On: nette/tester nette/utils nette/di nette/http
Blocks: 1277470 nette/bootstrap nette/nette
  Show dependency treegraph
 
Reported: 2015-11-03 04:46 EST by Remi Collet
Modified: 2015-12-28 22:54 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-05 03:13:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
shawn: fedora‑review+


Attachments (Terms of Use)
phpcompatinfo-full.log (6.37 KB, text/plain)
2015-12-01 16:39 EST, Shawn Iwinski
no flags Details
phpcompatinfo-lib.log (5.74 KB, text/plain)
2015-12-01 16:39 EST, Shawn Iwinski
no flags Details
fedora-review.txt (7.06 KB, text/plain)
2015-12-01 16:40 EST, Shawn Iwinski
no flags Details

  None (edit)
Description Remi Collet 2015-11-03 04:46:31 EST
Spec URL: https://raw.githubusercontent.com/remicollet/remirepo/26b8de8e5137f1d1c0df1793d89b43fa8a206b34/php/nette/php-nette-security/php-nette-security.spec
SRPM URL: http://rpms.famillecollet.com/SRPMS/php-nette-security-2.3.1-1.remi.src.rpm
Description: 
Nette Security: Access Control
- user login and logout
- verifying user privileges
- securing against vulnerabilities
- how to create custom authenticators and authorizators
- Access Control List

To use this library, you just have to add, in your project:
  require_once '/usr/share/php/Nette/Security/autoload.php';

Fedora Account System Username: remi
Comment 1 Shawn Iwinski 2015-12-01 16:39 EST
Created attachment 1101093 [details]
phpcompatinfo-full.log

phpCompatInfo version 4.5.1 DB built Oct 11 2015 19:52:03 CEST
Comment 2 Shawn Iwinski 2015-12-01 16:39 EST
Created attachment 1101095 [details]
phpcompatinfo-lib.log

phpCompatInfo version 4.5.1 DB built Oct 11 2015 19:52:03 CEST
Comment 3 Shawn Iwinski 2015-12-01 16:40 EST
Created attachment 1101096 [details]
fedora-review.txt

Generated by fedora-review 0.6.0 (3c5c9d7) last change: 2015-05-20
Command line :/usr/bin/fedora-review -m fedora-rawhide-x86_64 -b 1277418
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, PHP, Shell-api
Disabled plugins: Java, C/C++, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, Ruby
Disabled flags: EXARCH, DISTTAG, EPEL5, BATCH, EPEL6
Comment 4 Shawn Iwinski 2015-12-01 16:41:36 EST
[!]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
     Note: rm -rf %{buildroot} present but not required
[!]: Each %files section contains %defattr if rpm < 4.4
     Note: %defattr present but not needed
[!]: Buildroot is not present
     Note: Buildroot: present but not needed
[!]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
     Note: %clean present but not required

As usual, remove EPEL 5 bits after initial import.



No blockers.

===== APPROVED =====
Comment 5 Remi Collet 2015-12-02 01:04:41 EST
Thanks!

SCM request open on pkgdb.
Comment 6 Gwyn Ciesla 2015-12-02 09:20:00 EST
Package request has been approved: https://admin.fedoraproject.org/pkgdb/package/php-nette-security
Comment 7 Fedora Update System 2015-12-02 10:06:07 EST
php-nette-security-2.3.1-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-ae9b1f96ba
Comment 8 Fedora Update System 2015-12-02 10:06:07 EST
php-nette-security-2.3.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-4509a1f056
Comment 9 Fedora Update System 2015-12-02 10:06:13 EST
php-nette-security-2.3.1-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-1cd4bbb80c
Comment 10 Fedora Update System 2015-12-02 23:20:15 EST
php-nette-security-2.3.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update php-nette-security'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-4509a1f056
Comment 11 Fedora Update System 2015-12-03 11:01:32 EST
php-nette-security-2.3.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update php-nette-security'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-565aafb10c
Comment 12 Fedora Update System 2015-12-03 12:19:16 EST
php-nette-security-2.3.1-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update php-nette-security'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-ae9b1f96ba
Comment 13 Fedora Update System 2015-12-03 20:36:28 EST
php-nette-security-2.3.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update php-nette-security'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-1cd4bbb80c
Comment 14 Fedora Update System 2015-12-15 08:24:31 EST
php-nette-security-2.3.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2015-12-15 10:21:20 EST
php-nette-security-2.3.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2015-12-28 16:26:57 EST
php-nette-security-2.3.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 17 Fedora Update System 2015-12-28 22:54:01 EST
php-nette-security-2.3.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.