Bug 12775 - mkinitrd does not detect linear raid
Summary: mkinitrd does not detect linear raid
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
: 11082 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-21 08:15 UTC by Per Steinar Iversen
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-12 23:37:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Per Steinar Iversen 2000-06-21 08:15:14 UTC
mkinitrd does not detect linear raid in /etc/raidtab. 

It is also sensitive to TAB/SPACE in raidtab.

The following modification solves these problems, note that mkinitrd
contains a tab, so that the bugzilla web interface will
probably slightly destroy this diff.

--- mkinitrd    Wed Jun 21 10:05:21 2000
+++ mkinitrd.mod        Wed Jun 21 09:52:43 2000
@@ -210,11 +210,14 @@
 if [ -z "$noraid" ]; then
     # load appropriate raid devices if necessary
     if grep '^/dev/md' $fstab | grep -v noauto >/dev/null 2>&1 ; then
-       for number in $(grep '^[        ]*raid-level' /etc/raidtab |
+       for number in $(grep '^[[:space:]]*raid-level' /etc/raidtab |
                          awk '{print $2}' | LC_ALL=C sort -u) ; do
            case $number in
            [0145])
                findmodule "" raid$number
+               ;;
+           linear)
+               findmodule "" linear
                ;;
            *)
                echo "raid level $number (in /etc/raidtab) not recognized"
>&2

This works well here, people using the linear raid facility have less
problems with updating kernels.

-psi

Comment 1 Arenas Belon, Carlo Marcelo 2001-02-12 23:37:53 UTC
*** Bug 11082 has been marked as a duplicate of this bug. ***

Comment 2 Erik Troan 2002-05-21 22:13:21 UTC
fixed (finally!) in mkinitrd 3.3.11

we don't have any linear raid machines around here though, so it hasn't been
thoroughly tested -- patch is nearly identical to yours though


Note You need to log in before you can comment on or make changes to this bug.