Bug 1277533 - stop-all-gluster-processes.sh doesn't return correct return status
stop-all-gluster-processes.sh doesn't return correct return status
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ramesh N
:
Depends On:
Blocks: 1277562 1279776
  Show dependency treegraph
 
Reported: 2015-11-03 09:11 EST by Ramesh N
Modified: 2016-06-16 09:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1277562 1279776 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:42:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ramesh N 2015-11-03 09:11:30 EST
Description of problem:

stop-all-gluster-processes.sh doesn't return correct return status after successful completion.

How reproducible:

Always.

Steps to Reproduce:
1. run "stop-all-gluster-processes.sh" to kill all gluster process
2. # echo $?


Actual results:

 1

Expected results:

0
Comment 1 Vijay Bellur 2015-11-03 09:12:20 EST
REVIEW: http://review.gluster.org/11739 (extras: Exit with SUCCESS if no processes to stop) posted (#7) for review on master by Ramesh N (rnachimu@redhat.com)
Comment 2 Vijay Bellur 2015-11-03 09:38:44 EST
REVIEW: http://review.gluster.org/11739 (extras: Exit with SUCCESS if no processes to stop) posted (#8) for review on master by Ramesh N (rnachimu@redhat.com)
Comment 3 Niels de Vos 2016-06-16 09:42:46 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.