Bug 1279776 - stop-all-gluster-processes.sh doesn't return correct return status
stop-all-gluster-processes.sh doesn't return correct return status
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ramesh N
:
Depends On: 1277533
Blocks: 1277562
  Show dependency treegraph
 
Reported: 2015-11-10 04:36 EST by Ramesh N
Modified: 2016-04-19 03:47 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1277533
Environment:
Last Closed: 2016-04-19 03:47:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ramesh N 2015-11-10 04:36:01 EST
+++ This bug was initially created as a clone of Bug #1277533 +++

Description of problem:

stop-all-gluster-processes.sh doesn't return correct return status after successful completion.

How reproducible:

Always.

Steps to Reproduce:
1. run "stop-all-gluster-processes.sh" to kill all gluster process
2. # echo $?


Actual results:

 1

Expected results:

0

--- Additional comment from Vijay Bellur on 2015-11-03 09:12:20 EST ---

REVIEW: http://review.gluster.org/11739 (extras: Exit with SUCCESS if no processes to stop) posted (#7) for review on master by Ramesh N (rnachimu@redhat.com)

--- Additional comment from Vijay Bellur on 2015-11-03 09:38:44 EST ---

REVIEW: http://review.gluster.org/11739 (extras: Exit with SUCCESS if no processes to stop) posted (#8) for review on master by Ramesh N (rnachimu@redhat.com)
Comment 1 Vijay Bellur 2015-11-11 23:02:52 EST
REVIEW: http://review.gluster.org/12564 (extras: Exit with SUCCESS if no processes to stop) posted (#3) for review on release-3.7 by Ramesh N (rnachimu@redhat.com)
Comment 2 Vijay Bellur 2015-11-12 02:28:00 EST
COMMIT: http://review.gluster.org/12564 committed in release-3.7 by Venky Shankar (vshankar@redhat.com) 
------
commit 1e746edf35f5e1dd62f189fdc6c045a5d1482fa8
Author: Shubhendu Tripathi <shtripat@redhat.com>
Date:   Wed Jul 22 16:55:06 2015 +0530

    extras: Exit with SUCCESS if no processes to stop
    
    This script might be executed even when there are no
    valid processes running to be stopped. In this scenario,
    the script should return with SUCCESS
    
    Change-Id: Ia293214a4b5052bc4bef9769f197f7b05c55ffe9
    BUG: 1279776
    Signed-off-by: Shubhendu Tripathi <shtripat@redhat.com>
    Reviewed-on: http://review.gluster.org/11739
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/12564
    Tested-by: Ramesh N <rnachimu@redhat.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
Comment 3 Mike McCune 2016-03-28 19:29:58 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Kaushal 2016-04-19 03:47:50 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.