Bug 1277604 - Satellite 6.1.4 Installation on RHEL7.2 fails due to libdb dependency issue
Satellite 6.1.4 Installation on RHEL7.2 fails due to libdb dependency issue
Status: CLOSED DUPLICATE of bug 1277324
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Packaging (Show other bugs)
6.1.4
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On: 1228709
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 11:10 EST by Lukas Pramuk
Modified: 2015-11-03 11:51 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1228709
Environment:
Last Closed: 2015-11-03 11:51:52 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Lukas Pramuk 2015-11-03 11:24:48 EST
Satellite 6.1.4 Compose-{1,2} installation on RHEL7.2 candidate fails due to libdb dependency issue. Sat6 compose contains libdb-cxx package that requires you to downgrade libdb package that has been installed with RHEL7.2
We need to update libdb-* packages on Satellite compose(5.3.21-17.el7_0.1) to at least RHEL7.2 version(5.3.21-19.el7)

Version-Release number of selected component (if applicable):
Satellite-6.1.0-RHEL-7-20151030.2

How reproducible:
100%

Steps to Reproduce:
0.# rpm -qa|grep libdb
libdb-devel-5.3.21-19.el7.x86_64
libdb-5.3.21-19.el7.x86_64
libdb-utils-5.3.21-19.el7.x86_64

1.# yum -y install katello
...
--> Finished Dependency Resolution
Error: Package: libdb-cxx-5.3.21-17.el7_0.1.x86_64 (sat6-Satellite-6.1.0-RHEL-7-20151030.2-Satellite-x86_64-dvd1.iso)
           Requires: libdb(x86-64) = 5.3.21-17.el7_0.1
           Installed: libdb-5.3.21-19.el7.x86_64 (@beaker-Server/7.2)
               libdb(x86-64) = 5.3.21-19.el7
           Available: libdb-5.3.21-17.el7.x86_64 (rhel-7-server-rpms)
               libdb(x86-64) = 5.3.21-17.el7
           Available: libdb-5.3.21-17.el7_0.1.x86_64 (rhel-7-server-rpms)
               libdb(x86-64) = 5.3.21-17.el7_0.1
Comment 3 Lukas Pramuk 2015-11-03 11:51:52 EST

*** This bug has been marked as a duplicate of bug 1277324 ***

Note You need to log in before you can comment on or make changes to this bug.