Bug 1277693 - NetworkManager-openconnect fails
NetworkManager-openconnect fails
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
22
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
: 1278265 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-03 15:37 EST by Slava
Modified: 2015-11-17 13:23 EST (History)
7 users (show)

See Also:
Fixed In Version: NetworkManager-1.0.6-8.fc23 NetworkManager-1.0.6-8.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-08 01:50:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Slava 2015-11-03 15:37:00 EST
Description of problem:

NetworkManager Openconnect fail establish vpn from web ui.


Nov  3 15:24:11 2z49tz1 NetworkManager[1189]: <info>  Starting VPN service 'openconnect'...
Nov  3 15:24:11 2z49tz1 NetworkManager[1189]: <info>  VPN service 'openconnect' started (org.freedesktop.NetworkManager.openconnect), PID 22016
Nov  3 15:24:11 2z49tz1 gnome-session: (gnome-shell:2163): Gjs-WARNING **: JS ERROR: TypeError: a._connection is null
Nov  3 15:24:11 2z49tz1 gnome-session: NMVPNSection<.setActiveConnections/<@resource:///org/gnome/shell/ui/status/network.js:1533
Nov  3 15:24:11 2z49tz1 gnome-session: NMVPNSection<.setActiveConnections@resource:///org/gnome/shell/ui/status/network.js:1532
Nov  3 15:24:11 2z49tz1 gnome-session: wrapper@resource:///org/gnome/gjs/modules/lang.js:169
Nov  3 15:24:11 2z49tz1 gnome-session: NMApplet<._syncVPNConnections@resource:///org/gnome/shell/ui/status/network.js:1821
Nov  3 15:24:11 2z49tz1 gnome-session: wrapper@resource:///org/gnome/gjs/modules/lang.js:169
Nov  3 15:24:11 2z49tz1 NetworkManager[1189]: <info>  VPN service 'openconnect' appeared; activating connections
Nov  3 15:24:11 2z49tz1 gnome-session: (gnome-shell:3552): GLib-CRITICAL **: g_source_remove: assertion 'tag > 0' failed
Nov  3 15:24:12 2z49tz1 pcscd: 99999999 winscard.c:263:SCardConnect() Reader E-Gate 0 0 Not Found
Nov  3 15:24:32 2z49tz1 NetworkManager[1189]: <info>  VPN service 'openconnect' disappeared
Nov  3 15:24:32 2z49tz1 NetworkManager[1189]: <warn>  error disconnecting VPN: The name org.freedesktop.NetworkManager.openconnect was not provided by any .service files




Version-Release number of selected component (if applicable):

[volga629@vm ~]$ rpm -qa | grep NetworkManager-openconnect
NetworkManager-openconnect-1.0.2-1.fc22.x86_64



How reproducible:

100% 
Always

Steps to Reproduce:
1. Define vpn profile in NetworkManager GUI.
2. Start connection, enter credentials.
3. Connection will stop after some period of time.

Actual results:

See description above

Expected results:

Establish vpn connection

Additional info:

None
Comment 1 David Woodhouse 2015-11-04 04:59:15 EST
From a terminal as root, please run
/usr/libexec/nm-openconnect-service --debug --persist

Then try making the connection.

I suspect it'll work, and we'll be left none the wiser about why the normal invocation of the service failed. I am concerned by how fragile this is, and by the fact that we're adding *more* complexity to it... 

Tag...
Comment 2 Slava 2015-11-04 08:22:56 EST
[volga629@2z49tz1 ~]$ sudo /usr/libexec/nm-openconnect-service --debug --persist
** Message: nm-openconnect-service (version 1.0.2) starting...

** (nm-openconnect-service:5545): WARNING **: property 'cookie-flags' unknown

** (nm-openconnect-service:5545): WARNING **: property 'certsigs-flags' unknown

** (nm-openconnect-service:5545): WARNING **: property 'lasthost-flags' unknown

** (nm-openconnect-service:5545): WARNING **: property 'autoconnect-flags' unknown

** (nm-openconnect-service:5545): WARNING **: property 'gateway-flags' unknown

** (nm-openconnect-service:5545): WARNING **: property 'gwcert-flags' unknown

** (nm-openconnect-service:5545): WARNING **: property 'xmlconfig-flags' unknown

** (nm-openconnect-service:5545): WARNING **: property 'xmlconfig' unknown

** (nm-openconnect-service:5545): WARNING **: property 'lasthost' unknown
connection
	id : "Conn-SSL" (s)
	uuid : "180f29fa-ab2d-4501-8b2a-20a937121465" (s)
	interface-name : NULL (sd)
	type : "vpn" (s)
	permissions : user:volga629: (s)
	autoconnect : FALSE (s)
	timestamp : 0 (sd)
	read-only : FALSE (sd)
	zone : "home" (s)
	master : NULL (sd)
	slave-type : NULL (sd)
	secondaries :  (sd)
	gateway-ping-timeout : 0 (sd)


vpn
	service-type : "org.freedesktop.NetworkManager.openconnect" (s)
	user-name : "volga629" (s)
	persistent : FALSE (sd)
	data : enable_csd_trojan=no,xmlconfig-flags=0,pem_passphrase_fsid=no,gwcert-flags=2,gateway-flags=2,autoconnect-flags=0,lasthost-flags=0,stoken_source=manual,certsigs-flags=0,cookie-flags=2,gateway=1.1.1.1:443,authtype=password (s)
	secrets : gateway=1.1.1.1:443,cookie=4 (s)


ipv6
	method : "auto" (s)
	dhcp-hostname : NULL (sd)
	dns :  (s)
	dns-search :  (sd)
	addresses :  (s)
	routes :  (s)
	route-metric : -1 (sd)
	ignore-auto-routes : FALSE (sd)
	ignore-auto-dns : FALSE (sd)
	never-default : FALSE (sd)
	may-fail : TRUE (sd)
	ip6-privacy : -1 (sd)


ipv4
	method : "auto" (s)
	dns :  (s)
	dns-search :  (sd)
	addresses :  (s)
	routes :  (s)
	route-metric : -1 (sd)
	ignore-auto-routes : FALSE (sd)
	ignore-auto-dns : FALSE (sd)
	dhcp-client-id : NULL (sd)
	dhcp-send-hostname : TRUE (sd)
	dhcp-hostname : NULL (sd)
	never-default : FALSE (sd)
	may-fail : TRUE (sd)



** (nm-openconnect-service:5545): WARNING **: Created tundev vpn0

** Message: openconnect started with pid 5637
Comment 3 Slava 2015-11-04 08:23:42 EST
(In reply to Slava from comment #2)
> [volga629@2z49tz1 ~]$ sudo /usr/libexec/nm-openconnect-service --debug
> --persist
> ** Message: nm-openconnect-service (version 1.0.2) starting...
> 
> ** (nm-openconnect-service:5545): WARNING **: property 'cookie-flags' unknown
> 
> ** (nm-openconnect-service:5545): WARNING **: property 'certsigs-flags'
> unknown
> 
> ** (nm-openconnect-service:5545): WARNING **: property 'lasthost-flags'
> unknown
> 
> ** (nm-openconnect-service:5545): WARNING **: property 'autoconnect-flags'
> unknown
> 
> ** (nm-openconnect-service:5545): WARNING **: property 'gateway-flags'
> unknown
> 
> ** (nm-openconnect-service:5545): WARNING **: property 'gwcert-flags' unknown
> 
> ** (nm-openconnect-service:5545): WARNING **: property 'xmlconfig-flags'
> unknown
> 
> ** (nm-openconnect-service:5545): WARNING **: property 'xmlconfig' unknown
> 
> ** (nm-openconnect-service:5545): WARNING **: property 'lasthost' unknown
> connection
> 	id : "Conn-SSL" (s)
> 	uuid : "180f29fa-ab2d-4501-8b2a-20a937121465" (s)
> 	interface-name : NULL (sd)
> 	type : "vpn" (s)
> 	permissions : user:volga629: (s)
> 	autoconnect : FALSE (s)
> 	timestamp : 0 (sd)
> 	read-only : FALSE (sd)
> 	zone : "home" (s)
> 	master : NULL (sd)
> 	slave-type : NULL (sd)
> 	secondaries :  (sd)
> 	gateway-ping-timeout : 0 (sd)
> 
> 
> vpn
> 	service-type : "org.freedesktop.NetworkManager.openconnect" (s)
> 	user-name : "volga629" (s)
> 	persistent : FALSE (sd)
> 	data :
> enable_csd_trojan=no,xmlconfig-flags=0,pem_passphrase_fsid=no,gwcert-flags=2,
> gateway-flags=2,autoconnect-flags=0,lasthost-flags=0,stoken_source=manual,
> certsigs-flags=0,cookie-flags=2,gateway=1.1.1.1:443,authtype=password (s)
> 	secrets : gateway=1.1.1.1:443,cookie=4 (s)
> 
> 
> ipv6
> 	method : "auto" (s)
> 	dhcp-hostname : NULL (sd)
> 	dns :  (s)
> 	dns-search :  (sd)
> 	addresses :  (s)
> 	routes :  (s)
> 	route-metric : -1 (sd)
> 	ignore-auto-routes : FALSE (sd)
> 	ignore-auto-dns : FALSE (sd)
> 	never-default : FALSE (sd)
> 	may-fail : TRUE (sd)
> 	ip6-privacy : -1 (sd)
> 
> 
> ipv4
> 	method : "auto" (s)
> 	dns :  (s)
> 	dns-search :  (sd)
> 	addresses :  (s)
> 	routes :  (s)
> 	route-metric : -1 (sd)
> 	ignore-auto-routes : FALSE (sd)
> 	ignore-auto-dns : FALSE (sd)
> 	dhcp-client-id : NULL (sd)
> 	dhcp-send-hostname : TRUE (sd)
> 	dhcp-hostname : NULL (sd)
> 	never-default : FALSE (sd)
> 	may-fail : TRUE (sd)
> 
> 
> 
> ** (nm-openconnect-service:5545): WARNING **: Created tundev vpn0
> 
> ** Message: openconnect started with pid 5637

I tested for fedora 22 x86_64 and fedora 23 x86_64 result the same. From shell works, connects can browser the lan. From GUI both not working connection status just disappeared after 20 sec.
Comment 4 David Woodhouse 2015-11-04 08:54:50 EST
Yes, I see this occasionally. For me it's undebuggable. I don't know where to start looking. I just stick with the workaround.

I appreciate this is not an ideal answer. Reassigning to NetworkManager itself, since the problem is with generic code (or with D-Bus activation, or something).
Comment 5 David Woodhouse 2015-11-05 04:43:19 EST
*** Bug 1278265 has been marked as a duplicate of this bug. ***
Comment 6 David Woodhouse 2015-11-05 04:45:29 EST
I've marked bug 1278265 as a duplicate of this, which I think it might be. Mike observed in that bug that it seems to be a timeout issue — if the authentication doesn't complete fast enough, then the service quits.
Comment 7 Jirka Klimes 2015-11-05 08:51:43 EST
If this is the problem of short timeout (20 seconds), it is fixed upstream by
http://cgit.freedesktop.org/NetworkManager/NetworkManager/commit/?id=b1512221bc29f24b86d464dc5117439c366fd299
Comment 8 Fedora Update System 2015-11-05 11:27:47 EST
NetworkManager-1.0.6-8.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-bbc8935459
Comment 9 Fedora Update System 2015-11-05 11:27:49 EST
NetworkManager-1.0.6-8.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-38fc6652a8
Comment 10 Fedora Update System 2015-11-05 19:50:51 EST
NetworkManager-1.0.6-8.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update NetworkManager'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-38fc6652a8
Comment 11 Fedora Update System 2015-11-05 21:34:08 EST
NetworkManager-1.0.6-8.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update NetworkManager'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-bbc8935459
Comment 12 Fedora Update System 2015-11-08 01:50:22 EST
NetworkManager-1.0.6-8.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2015-11-17 13:23:11 EST
NetworkManager-1.0.6-8.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.