Bug 1278265 - openconnect VPN client fails to connect
openconnect VPN client fails to connect
Status: CLOSED DUPLICATE of bug 1277693
Product: Fedora
Classification: Fedora
Component: NetworkManager-openconnect (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: David Woodhouse
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-05 01:34 EST by Mike Norwood
Modified: 2015-11-05 04:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-05 04:43:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Norwood 2015-11-05 01:34:12 EST
Description of problem:
When initializing a VPN connection via NetworkManager VPN connection applet, the connection terminates before the authentication completes. 

Version-Release number of selected component (if applicable):
NetworkManager-openconnect.x86_64     1.0.2-2.fc23

How reproducible:
Always

Steps to Reproduce:
1. Open Settings 
2. Click Network 
3. Click (+) to add new connection 
4. Choose VPN 
5. Choose Cisco AnyConnect Compatible VPN (openconnect)
6. Enter VPN connection information
7. Click Add
8. Click applet in taskbar at top right
9. Select VPN Off to expand
10. Select Connect
11. In VPN Connect/Authentication popup window, enter credentials
12. Enter dual factor token or 'push' 
13. Click Login

Actual results:
VPN Connect/Authentication popup window closes but connection is not made.

Expected results:
VPN Connect/Authentication popup window closes and connection is made.

Additional info:
This appears to be due to a very short timeout in the client.  If all authentication information is prepared prior to clicking connect in the popup window and entered quickly, the connection does succeed.  This is very difficult at best when dealing with MFA systems.  It seems as though it is a regression as this was not the case in Fedora 22.
Comment 1 Mike Norwood 2015-11-05 01:41:08 EST
Relevant log entries:

Nov 05 01:36:48 fedora23 NetworkManager[1302]: <info>  Starting VPN service 'openconnect'...
Nov 05 01:36:48 fedora23 NetworkManager[1302]: <info>  VPN service 'openconnect' started (org.freedesktop.NetworkManager.openconnect), PID 8278
Nov 05 01:36:48 fedora23 gnome-session[1652]: (gnome-shell:1688): Gjs-WARNING **: JS ERROR: TypeError: a._connection is null
Nov 05 01:36:48 fedora23 gnome-session[1652]: NMVPNSection<.setActiveConnections/<@resource:///org/gnome/shell/ui/status/network.js:1534
Nov 05 01:36:48 fedora23 gnome-session[1652]: NMVPNSection<.setActiveConnections@resource:///org/gnome/shell/ui/status/network.js:1533
Nov 05 01:36:48 fedora23 gnome-session[1652]: wrapper@resource:///org/gnome/gjs/modules/lang.js:169
Nov 05 01:36:48 fedora23 gnome-session[1652]: NMApplet<._syncVPNConnections@resource:///org/gnome/shell/ui/status/network.js:1822
Nov 05 01:36:48 fedora23 gnome-session[1652]: wrapper@resource:///org/gnome/gjs/modules/lang.js:169
Nov 05 01:36:48 fedora23 NetworkManager[1302]: <info>  VPN service 'openconnect' appeared; activating connections
Nov 05 01:36:48 fedora23 gnome-session[2325]: (gnome-shell:2527): GLib-CRITICAL **: g_source_remove: assertion 'tag > 0' failed
Nov 05 01:37:08 fedora23 NetworkManager[1302]: <info>  VPN service 'openconnect' disappeared
Nov 05 01:37:08 fedora23 NetworkManager[1302]: <warn>  error disconnecting VPN: The name org.freedesktop.NetworkManager.openconnect was not provided by any .service files
Nov 05 01:37:12 fedora23 gnome-keyring-daemon[2190]: asked to register item /org/freedesktop/secrets/collection/login/4, but it's already registered
Nov 05 01:37:12 fedora23 gnome-keyring-daemon[2190]: asked to register item /org/freedesktop/secrets/collection/login/5, but it's already registered
Nov 05 01:37:12 fedora23 gnome-session[2325]: ** (gnome-shell:2527): CRITICAL **: shell_network_agent_set_password: assertion 'request != NULL' failed
Nov 05 01:37:12 fedora23 gnome-session[2325]: ** (gnome-shell:2527): CRITICAL **: shell_network_agent_set_password: assertion 'request != NULL' failed
Nov 05 01:37:12 fedora23 gnome-session[2325]: ** (gnome-shell:2527): CRITICAL **: shell_network_agent_set_password: assertion 'request != NULL' failed
Nov 05 01:37:12 fedora23 gnome-session[2325]: ** (gnome-shell:2527): CRITICAL **: shell_network_agent_set_password: assertion 'request != NULL' failed
Nov 05 01:37:12 fedora23 gnome-session[2325]: ** (gnome-shell:2527): CRITICAL **: shell_network_agent_set_password: assertion 'request != NULL' failed
Nov 05 01:37:12 fedora23 gnome-session[2325]: ** (gnome-shell:2527): CRITICAL **: shell_network_agent_set_password: assertion 'request != NULL' failed
Nov 05 01:37:12 fedora23 gnome-session[2325]: ** (gnome-shell:2527): CRITICAL **: shell_network_agent_set_password: assertion 'request != NULL' failed
Nov 05 01:37:12 fedora23 gnome-session[2325]: ** (gnome-shell:2527): CRITICAL **: shell_network_agent_set_password: assertion 'request != NULL' failed
Nov 05 01:37:12 fedora23 gnome-session[2325]: ** (gnome-shell:2527): CRITICAL **: shell_network_agent_set_password: assertion 'request != NULL' failed
Comment 2 David Woodhouse 2015-11-05 04:43:19 EST

*** This bug has been marked as a duplicate of bug 1277693 ***

Note You need to log in before you can comment on or make changes to this bug.