Bug 1277841 - gdeploy uses deprecated default tuned profile
gdeploy uses deprecated default tuned profile
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity medium
: ---
: RHGS 3.1.3
Assigned To: Sachidananda Urs
Anush Shetty
: ZStream
Depends On:
Blocks: 1299184
  Show dependency treegraph
 
Reported: 2015-11-04 03:36 EST by Martin Bukatovic
Modified: 2016-06-23 01:29 EDT (History)
4 users (show)

See Also:
Fixed In Version: gdeploy-2.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 01:29:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Bukatovic 2015-11-04 03:36:42 EST
Description of problem
======================

By default, gdeploy uses rhs-high-throughput tuned profile on both rhel 6
and rhel 7 based gluster storage servers. According to our docs, this is wrong
approach:

> Earlier versions of Red Hat Gluster Storage on Red Hat Enterprise Linux 6
> recommended tuned profiles rhs-high-throughput and rhs-virtualization. These
> profiles are still available on Red Hat Enterprise Linux 6. However,
> switching to the new profiles is recommended. 

List of new recommended tuned profiles (from table 11.1. Recommended Profiles
for Different Workloads):

* Large-file, sequential I/O workloads: rhgs-sequential-io
* Small-file workloads: rhgs-random-io
* Random I/O workloads: rhgs-random-io

See section 11.2. Brick Configuration of Admin Guide:

https://access.redhat.com/documentation/en-US/Red_Hat_Storage/3.1/html/Administration_Guide/Brick_Configuration.html

Version-Release number of selected component (if applicable)
============================================================

gdeploy-1.0-12.el6rhs.noarch

How reproducible
================

100 %

Steps to Reproduce
==================

1. Use gdeploy to setup Trusted Storage Pool without specifying tuned profile
   in gluster.conf file
2. Check tuned profile activated on gluster storage server machines
   using `tuned-adm active` command.

Try this with both rhel 6 and rhel 7 storage server machines.

Actual results
==============

i) On rhel 6 storage servers, rhs-high-throughput profile was activated:

~~~
# tuned-adm active
Current active profile: rhs-high-throughput
Service tuned: enabled, running
Service ktune: enabled, running
~~~

This is wrong default choice, because rhgs-sequential-io is now recommended.

ii) On rhel 7, no profile is activated. Gdeploy fails on task called
"Performance tune for general storage" with this message:

~~~
stderr: Requested profile 'rhs-high-throughput' doesn't exist.
~~~

As storage documentation points out, this is expected as the older profile is
not available on rhel7 machines. Unfortunately this outcome is even worse,
because admin would be confused and try to find problem in gluster.conf while
the problem is in wrong default configuration.

Expected results
================

On both rhel6 and rhel7, gdeploy uses  rhgs-sequential-io as default tuned
profile.

Additional info
===============

https://access.redhat.com/solutions/2023633
https://bugzilla.redhat.com/show_bug.cgi?id=1260597
Comment 1 Nandaja Varma 2015-11-04 03:44:53 EST
This behavior has been changed in the next release version. Now, by default gdeploy does not assume a profile anymore. If not specified, tuned-adm will not be called at all. User should specify explicitly which profile is to be set, if at all needed.
Comment 3 Martin Bukatovic 2015-11-06 09:04:46 EST
See BZ 1249979, RHGSC is updating list of tuned profiles as well.
Comment 4 Nandaja Varma 2015-11-24 02:10:21 EST
Fixed in release 1.1.
Comment 6 Anush Shetty 2016-04-12 04:26:53 EDT
Tested for rhgs-sequential-io and rhgs-random-io. Verified with gdeploy-2.0-5.el7rhgs.noarch
Comment 8 errata-xmlrpc 2016-06-23 01:29:06 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1250

Note You need to log in before you can comment on or make changes to this bug.