Bug 127796 - fc3t1 crashes during install - anaconda text dump provided
fc3t1 crashes during install - anaconda text dump provided
Status: CLOSED DUPLICATE of bug 127713
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-13 19:20 EDT by Jim Cornette
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump on upgrade attempt, 1st try (741.46 KB, text/plain)
2004-07-13 19:25 EDT, Jim Cornette
no flags Details
Second attempt to upgrade - No release notes tried (739.38 KB, text/plain)
2004-07-13 20:09 EDT, Jim Cornette
no flags Details
went to debug mode - cp to floppy anacdump.txt from fc2 clean (698.05 KB, text/plain)
2004-07-13 20:44 EDT, Jim Cornette
no flags Details

  None (edit)
Description Jim Cornette 2004-07-13 19:20:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
After downloading,md5sum, mediachecking installation cds with no
errors reported, the following dump happened for an upgrade.

Selected system to upgrade. OK
selected customize boot loader. OK
Installation proceeded to transfer image.

When I clicked on the realease notes button on the install, a message
popped up to either debug, save to floppy or cancel. I first tried to
save to floppy, but the prompt seemed to always come back. I knew that
their would be a dump.txt in the root directory, so I let it cancel.

Attached to this report will be the dump for my attempt to install. I
am sure this will reveal more of the problem encountered. "Crashed
when trying to read the release notes" is probably not correct.



Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Boot CDROM 1 and start install.
2. Choose upgrade version desired to upgrade (/hdb2)
3. Customize boot loader for /dev/hdb1 to install grub and add
chainloader for /dev/hda1 (another linux version)
4. Watch installation seem to proceed
5. Click on release notes ... BOOM
6. Try to save to disk error message screen.
7. Reboot into system that was targeted for upgrade, no damage
    

Actual Results:  Things seemed to be proceeding with the upgrade until
I clicked on the release notes. Then dump provided.


Expected Results:  A brand new, bug free, fantastic version of FC3t1
should have installed

Additional info:

I will try to attach the output on the floppy and send the
anacrash.txt file. I tried the installation once.
Comment 1 Jim Cornette 2004-07-13 19:25:24 EDT
Created attachment 101876 [details]
dump on upgrade attempt, 1st try

First anaconda instalation attempt for FC3t1. If anything is on the floppy, it
will be attached also.
Comment 2 Jim Cornette 2004-07-13 19:28:43 EDT
No luck on any output to floppy. The disk was mountable and I was able
to add files to it. I am not sure what output would be on the floppy,
if successfully created.

Jim
Comment 3 Jim Cornette 2004-07-13 20:09:47 EDT
Created attachment 101879 [details]
Second attempt to upgrade - No release notes tried

This did the same thing on both attempts. Both attempt were with boot loader
the only change for upgrade options.
I am going to try to upgrade another installation on the same computer that has
no additional packages and was a clean install of FC2 next. No test
installation attempted.
Comment 4 Jim Cornette 2004-07-13 20:44:04 EDT
Created attachment 101880 [details]
went to debug mode - cp to floppy anacdump.txt from fc2 clean

I tried to upgrade a clean fc2 system to fc3t1 and was greeted with a similar
error. Out of curiousity, I chose debug and realized I did not know what to do.
I checked the other output screens and saw something related to selinux on a
screen. It said something like instPATH + "selinux". I found nothing in the
/mnt/sysimage/selinux directory.

I then created a directory to mount a floppy disk to. Then I mounted the disk.
Next, I changed to the /mnt/sysimage/root directory and tried to cp
anacdump.txt to my floppy disk. The file copied and is the attachment submitted
now.
Comment 5 Jeremy Katz 2004-07-13 22:48:21 EDT

*** This bug has been marked as a duplicate of 127713 ***
Comment 6 Barry K. Nathan 2004-07-13 23:57:31 EDT
BTW, the failure to dump the traceback onto the floppy is bug 127064.
Comment 7 Jim Cornette 2004-07-14 07:03:34 EDT
As an alternative to bug 127713 resolution, running the installer with 
linux selinux=0 will also allow the installation to complete successfully.
As of bug 127064 - I believe this might also be influenced by selinux
enabled also. Of course, without a dump, no save to floppy is needed.

A good idea would be to look into the save to floppy problem before
the removing the /selinux patch is implemented. This would squash 2
bugs and enable to save to floppy bug trace.

Jim
Comment 8 Barry K. Nathan 2004-07-14 08:18:53 EDT
selinux=0 does not prevent bug 127064 (I just tested, using bug 122605
as the trigger). Bug 127064 and 127713 are unrelated -- there's no way
to squash two bugs at once in this instance.
Comment 9 Jeremy Katz 2004-07-14 10:31:55 EDT
Both are actually fixed with rawhide (newer kernel fixes the save to
floppy and I fixed the silly thinko with the SELinux + upgrades)
Comment 10 Jim Cornette 2004-07-14 17:51:09 EDT
You might check out a problem when trying to mount a vfat partition
during install. I tried to mount a vfat partition during an install
and also an upgrade today. Both the update and install crashed when I
tried to give a mount point to a volume to share files from XP to
Fedora. Not setting up a mount point let the installer continue
without crashing.
This worked in FC2. Since this led me to think of just configuring the
vfat share similar to a floppy, (user mountable) it might be a feature.

Thanks!

Moving on to other bugs.
Comment 11 Red Hat Bugzilla 2006-02-21 14:04:26 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.