Bug 1278051 - All-In-One: sanlock: Cannot acquire host id
All-In-One: sanlock: Cannot acquire host id
Status: CLOSED DUPLICATE of bug 1305768
Product: vdsm
Classification: oVirt
Component: General (Show other bugs)
4.17.9
x86_64 Linux
high Severity medium (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Fred Rolland
Aharon Canan
storage
:
: 1278050 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-11-04 10:44 EST by Bo Lei
Modified: 2016-02-22 09:05 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 04:30:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
logs (1.38 MB, application/x-gzip)
2015-11-06 09:58 EST, Bo Lei
no flags Details

  None (edit)
Description Bo Lei 2015-11-04 10:44:05 EST
Description of problem:


Version-Release number of selected component (if applicable):
VDSM 4.17.999-XX

How reproducible:


Steps to Reproduce:
1.install ovirt 3.6 all-in-one
2.add local-datacenter
3.add local-cluster
4.add local-host
5.add local data storage domain for local-host


Actual results:
Error while executing action New Local Storage Domain: AcquireHostIdFailure

Expected results:
add local data storage domain success

Additional info:
log:
VDSM 172.168.1.98 command failed: Cannot acquire host id: (u'805bc73e-21d6-490f-9348-62b994e7f388', SanlockException(19, 'Sanlock lockspace add failure', 'No such device'))
Comment 1 Yaniv Kaul 2015-11-05 05:40:18 EST
*** Bug 1278050 has been marked as a duplicate of this bug. ***
Comment 2 Nir Soffer 2015-11-05 08:25:14 EST
Please attach logs:

/var/log/ovirt-engine/engine.log
/var/log/vdsm/vdsm.log
/var/log/sanlock.log
/var/log/messages
Comment 3 Bo Lei 2015-11-06 09:58 EST
Created attachment 1090682 [details]
logs

added all the logs.
Comment 4 Tal Nisan 2015-11-23 07:21:49 EST
Nir, any news on that one? Logs are attached
Comment 5 Nir Soffer 2015-12-07 07:30:32 EST
(In reply to Tal Nisan from comment #4)
I can check this next week.
Comment 6 Fred Rolland 2016-01-03 05:29:32 EST
Hi,

From the messages log, we can see that SE Linux is preventing Sanlock access:



Nov  4 22:20:49 localhost sanlock[16565]: 2015-11-04 22:20:49+0800 884 [17529]: open error -13 /rhev/data-center/mnt/_home_data/d65c4762-bd59-4ac7-ab49-4a05fa4d61dc/dom_md/ids
...

Nov  4 22:20:49 localhost python: SELinux is preventing /usr/sbin/sanlock from 'read, write' accesses on the file ids.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that sanlock should be allowed read write access on the ids file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep sanlock /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp
Comment 7 Fred Rolland 2016-01-03 06:54:35 EST
Bo hi,

Can you retry with SElinux on permissive mode ?

Also, can you please provide AVC log from SElinux ? - best way is with ausearch

Thanks,

Fred
Comment 8 Bo Lei 2016-01-03 09:07:51 EST
(In reply to Fred Rolland from comment #7)
> Bo hi,
> 
> Can you retry with SElinux on permissive mode ?
> 
> Also, can you please provide AVC log from SElinux ? - best way is with
> ausearch
> 
> Thanks,
> 
> Fred

I will retry this week.

Bo
Comment 9 Fred Rolland 2016-01-04 04:16:22 EST
I have checked on 7.2 and it works fine also on Enforcing mode.

Ovirt 3.6 should work with 7.2
Comment 10 Fred Rolland 2016-02-17 07:41:30 EST

*** This bug has been marked as a duplicate of bug 1305768 ***
Comment 11 Fred Rolland 2016-02-22 08:57:54 EST
This issue is not present in ovirt 3.6, it was introduced in master later (future 4.0.0)

Note You need to log in before you can comment on or make changes to this bug.